[UE5] Nanite bugged in new version of UE5?

Hey, I downloaded new version of UE5 and some of my nanite meshes have missing faces. For me nanite working like reduction tringles count, and not as nanite in the previous version.

Maybe I’m doing something wrong, but I did the same in the previous version and everything was fine.

Another problem is that entering View mode → Nanite Visalization - none of these view modes works.

Anyone have same bugs?

Cheers

10 Likes

Hi,
I think you have the same issue as I have:

I found out, that it’s a project bug, so something in the project saved the meshes the “wrong” way… or something in the project disables the nanite functionality. When I make a new project nanite works.

I think I found a solution. Starting a new, blank project seems to have no issues. I can enable nanite and everything is working fine.

Opening any project created with an earlier version of UE5, or opening any of the sample projects causes Nanite to bug out and stop working.

I haven’t checked if you can migrate assets yet, or if that causes problems. Will update after tests.

Update: Lyra works fine. Nanite has no problems. I’ve got two projects I created before release that are not working.

Update 2: Migrating DOES work.

1 Like

I also have the same problem.
There were no problems until ue5.0 preview2.

Right, I have project created in previous version so maybe its a project bug. I will create new project and and see if nanite will work.

Yes, that was also my plan, to migrate the project into a new one… but this is very complicated when you have a big project like mine (over 300GB). I hope there is a better solution…

1 Like

I also have same problem. I had no problem when I opened my file in UE5 Preview 1. I have another problem when I import STEP format 3D Models and Convert them to Nanite I get problem with the shadows but in UE5 Preview 1 I did not have this problem.

I created new project and nanite working fine, so maybe we need to wait for official bug fix :slight_smile:

Have you checked if your version of Win10 is new enough to support the required DX12 Agility SDK?
See here how to check: Getting Started with the Agility SDK - DirectX Developer Blog

I’m getting the same issue.

Converting an UE5 EA project into the latest, stable release of UE5 from a few hours ago will result in a project where every Nanite mesh gets displayed only with Nanite Fallback.

Going into the Viewport and changing to any Nanite Visualization produces a darkened view of the scene with no Nanite vis modes working.

Selecting all of the “faulty” Nanite meshes from Content Browser and clicking Nanite - Enable or Nanite - Disable does not do anything.
Going in meshes individually and ticking Nanite on or off from settings doesn’t change anything either.

CMD and typing r.Nanite 0 or r.Nanite 1 does not change or produce anything either.

I ended up making a blank UE5 latest release project. I then migrated the “broken” scene and all its geo from my non functioning converted project to it. I opened the migrated scene in the blank project and now suddenly everything works, Nanite and all the previously non working Nanite meshes included.

@SiggiG I do have DX12 Agility SDK support so that does not seem to be it.

4 Likes

Further tests:

Opening a blank project allows nanite to work.

Adding marketplace assets works (added the Apartment Tech Props to the scene, nanite worked fine on them)

Migrating seems to work, though some of the meshes looked like they were having issues, need to look into that more.

Not sure what the problem is, but something in the engine seems to just block off any project created from an earlier version from nanite. There doesn’t seem to be any way to undo this.

Edit: the Lyra project also works.

2 Likes

Switching to DX12 works, but it’s not a good solution (in my opinion).
Edit: Switching to Vulkan also works for me, but not sure how much this will affect the overall performance…

2 Likes

Found a solution.

Issue is the RHI in the Project Settings.

  1. Open Project Settings.
  2. Search RHI.
  3. Go Under Platforms - Windows - Targeted RHIs (presuming you are on that platform).
  4. Change from Default RHI: Default to DirectX 12.
  5. Restart the project.

That should solve it.

I always thought that Nanite is supported both on DirectX 11 and 12? At least I remember that being explained in the official docs last year. Newest release and updated docs mention only DirectX 12 and now I do wonder if that is the only one Nanite supports?

Just thinking out loud, would love to hear from someone more experienced so we could all learn!

P.S @Nexusmaster wrote the same answer while I was writing this : )

Cheers,
Pete.

18 Likes

Nanite now requires DX12 on Windows. DX11 is no longer supported.

Also need to make sure DirectX 12 (SM6, Experimental) is checked.

3 Likes

I tried this but Nanite does not work with my earlier projects even with DX12 enabled. I’m about to try migrating because that seems to have worked for a few others.

UPDATE: Nanite doesn’t work in new projects either.

1 Like

Nanite also works with Vulkan, which I will use now, because it supports more platforms.

1 Like

I can confirm, Nanite works with Vulkan so Vulkan it is for now.

1 Like

Nope, this was the first thing I tried. Someone actually posted this problem and solution from a few days ago, but it doesn’t work (at least on my end) with the release of UE5. The project was already set to DX12, but just in case, I tried disabling DX11, didn’t change anything.

I haven’t tried Vulkan yet, so we’ll see.

I have enabled RHI setting as DX12 and it’s working for me.

EDIT: Back in my original project, In project settings I changed RHI from default to DirectX12 and it fixed my issue as well. If that doesn’t work for you, try the steps below…

I was having this issue. But I did this and it worked:

1). Create a new blank project.
2). From original broken project, export your ‘input’ settings to file
3). From original project, take note of all installed and activated plugins
4). In new project, import your ‘input’ settings file
5). In new project, install / activate all required plugins from original project
6). Close all instances of UE
7). In windows file browser, manually copy the folders from your ‘content’ folder of the original project, to the ‘content’ folder of your new project
8). Open new project, let shaders compile
9). For me, after the shaders compiled (took forever) when I tried to open the map I was working on that was ‘nanite broken’, it looked like the computer froze when opening… I left the computer for 30 minutes and it eventually loaded
10). Continue working where you left off, nanite enabled :slight_smile:

NOTE: I tried to migrate the folders from inside unreal engine multiple times, and it crashed every time. When I did it manually it was all good… Hope this helps someone.

5 Likes