Why does my Metallic map make my mesh almost completely black?

This is how my mesh looks in Sketchfab:

This is how it looks in UE4 with the same settings:

I thought it might have been a glitch with the engine (4.16) so I updated to 4.20 but same results.

Usually?
Lack of reflection captures or a reflective environment.

Sorry, I should have given more scene details…

I’ve got a directional light in the scene with the default settings but set to moveable, I’ve got a skylight also set to moveable, I’ve set the environment color to white (instead of the default black), and I’ve got a sphere reflection capture and built lighting.

The only way I can get it even moderately close to looking correct is if I crank the skylight intensity up to 50 from the default 1 and I set my metallic and roughness to 0.8.
I should also mention that my metallic map is pure white as the entire ship is metal. The roughness is of course not…

I just assumed it would work under the default lighting settings. I’d imagine if I crank the skylight to 50 and dropped this into a regular environment (like a landscape) it’ll wash out the reset of the scene.

It doesn’t look like there’s any reflection on the ship at all - the clouds should be reflected in there from the capture, technically.

Did you try the different visualization modes to check on the various things / reflective env is one of those. There’s also one just for roughness that can help debug if the material is somehow inverted.

The last option would be to just use the could texture in the material manually like it’s done for Eye rendering. Obviously that won’t really be active at runtime.

The scene you have may not render correctly by default, but usually if you open the mesh, the preview should have the cube map correctly reflected into the item by default.

Yeah, that’s what I thought. I dropped it into another project and built lighting and same thing, it’s really dark… Not as bad, but still not good.

I combined my Rougness, Metallic and AO into a single TGA file to save memory and use that in the material. Roughness in the red channel, metallic in green and ao in blue… I’ve been using this method for years without issue. It looks mostly fine in the UE4 mesh viewer. It’s only when I drop it into a scene that it goes completely dark.

My material isn’t really complex either. Just the diffuse, normal, RMAO, Emissive and a color mask switch.

Make sure that your mixed textures like AO-RO-ME are NOT marked as SRGB!

If they are marked wrong the values are wrong.
It’s the first I always do when importing this kind of textures

Hmmm… Well, the SRGB definitely helped to make it look more like metal, but if anything it actually made the ship darker because the specularity went way down.
SRGB

Setting my Metallic to 0 is the only way I can improve the overall brightness of the ship. It’s really odd. This doesn’t seem like the expected behavior to me, but it’s happening across all projects.

Well hang on.
I’m metal rendering mode the brightness of the metal is driven by the albedo.
Purely reflective metals have a white albedo.

Altering albedo to the proper PBR values should result in the same look between PBR driven program(s) - or so you’d think anyway, when Reflections actually work.

It already looks like you are using the normal skysphere BP, however, let’s also confirm that.
Using sky atmosphere has been giving weird results on metallic since they added it. (You see the thing is they dgaf. Unless it’s something related to movie production or cartoonish fortnite rendering, they don’t really regard anything in the rendering pipeline as a problem, and they really never have…)

Top suggestion right now would be to get an asset from quixel that’s huge and mostly metal.
Throw it in the scene with the imported materials, and see how it looks.
If it looks bad, bugging quixel about it may result in epic actually addressing issues… :man_shrugging:

If it looks good, then there’s some other issue with your model/metal.

Top reason I can think of for coloring darker would be inverted normals with double-sided paint. I seriously doubt that’s your situation. You never know.

How does your reflection only view look?
Are the coulds being reflected?

Gotta love how Epic originally added PBR because it was so important to them to have physically based rendering - TBH, I much preferred ye old diffuse and specular. It’s easier to get the look you want - and now they dgaf.
So yeah, reflections only just looks like dark chrome… As you would expect from the first image, the bottom of the ship is nearly black…

Yeah, I realize chrome needs a white albedo to looks right, but this shouldn’t be rendering so dark when my roughness values are so high. If I set my roughness to 1, it’s still super dark which doesn’t make sense to me.

Yeah, it’s just a plain jane sky BP.
Normals aren’t inverted and the material isn’t double-sided either. I wonder what result I’d get if I imported Epic’s automotive materials and threw one of them on. My only frustration is that all of Epic’s material examples are for tiling, usually procedural materials. They don’t show any assets with baked textures. Good idea with a quixel asset, but I don’t really want to have to wait on them to fix something. lol.
The really weird thing though is that it looks fine in the model viewer, so why does it look like ■■■■ when I drop it into a map? Maybe the model viewer has a higher intensity lighting?

Just overall different light settings - and a cube map.
You did capture the skyklight right?

The reflection shot shows a bit of why the albedo isn’t working. That’s already Chrome, with the default reflective settings it should look much more closer to aluminum or a mirror (silver)…

Off hand, the reflection quality needs a bump. Way too fuzzy.
Test on a cube - you should be able to clearly see the reflection of the clouds at a somewhat similar quality.

Mind you, if you try the advanced search we already had a disucssion about this “change” for .26.

I doubt the automtive Chrome would work - but you never know?

Maybe I don’t know how to use the cubemap properly? lol I just dropped it into the level and built. That’s how the ones from Source worked. Is there another step with UE4?

I’m actually using 4.16 but this happens in 4.26 as well because that was the project for the desert environment I dropped it into.

Oh, sorry. I did do a search on the subject before I posted. All I found was a reddit post about the subject that the author apparently “fixed” with an engine update on their mac. I didn’t really think to search through the forums directly.

You wrote that your ship is becoming darker with higher roughness. Imho this is actually correct.

If less light is reflected (higher roughness) an object becomes darker. In real live you are blinded by glass (low roughness) and not by concrete (high roughness).

And furthermore, I think that you never can expect that an object looks identical in different software because they all render in different ways. So perhaps you have to tweak some parameters.

I personally use Substance Painter, for example. I always change a little bit of roughness values after importing to get the expected results.

I don’t think it is an engine problem.
Check your post processing and cubemap settings and the post processing of your camera. There are so many parameters which change the appearance of a game…

I said it’s still dark with a higher roughness value, not darker with a higher roughness. But no, increasing the roughness value decreases the reflectivity true, but it has the same effect of turning off the metallic, which actually brightens the mesh overall. Here’s a look at the mesh with the metallic set to 0:

The reason turning off the metallic makes the mesh brighter, is because of the fact that the albedo is dark, so in combination with the metallic being turned on, you end up with a dark mesh as MostHost_LA. pointed out. Ultimately, a fix would be to increase the brightness of the albedo. The frustration is that the mesh looks fine in Sketchfab with the default settings, and it looks fine in the UE4 mesh viewer with the default settings. It’s only when I put it in the world that it gets really dark. I’m throwing it into an empty world. There’s no PP and nothing wrong with the cube maps.
I’m not necessarily blaming the engine. I’m just looking for advice on how to come up with a better solution (beyond increasing the brightness of the albedo, but maybe that is the only fix).

Heck just do this:
https://forums.unrealengine.com/search?q=metal%20black%20%23development-discussion:rendering

BUT the engine is totally fine - yep - The rendering pipeline is Just perfect…
Another EPIC fail by Epic :stuck_out_tongue:

That said - try making all your light movable - skylight too - and give a quick glimpse to the ones I shared directly.

There’s another one in that pile somewhere with detailed info on each item you need to enable to get GOLD to look… well… gold… And silver to look silver, not Burnt Chimney™ (epic might as well trade mark this as their new PBR color)…

PS: The last screen-cap is just not metal enough. Not sure if you were testing without metal - but the Albedo looks about what I’d expect to get the initial sketchfab look. maybe It is a little on the dark side - but it shouldn’t really matter.
Enabling metal should make the item LIGHTER - as there’s a ■■■■ cloud white sky to reflect into it…

1 Like

Looks very much like the same issue I had, where if you have a static skylight, diffuse dissapears completely on metallic objects and you only get some highlights.


vs
2ccc1879b1d6ff774c6811006740cc0f254787d7_2_690x430

Making my skylight movable fixed it for me.

2 Likes

All my lights are moveable sadly. My workaround is to add a brightness multiplier to the albedo. It’s the most controllable solution.

You’ll want to check realtime capture on your skylight if all the lights are moveable.

Reflection captures will capture the lower hemisphere of the skydome as black with moveable skylights. Try going into your skylight properties and changing the lower hemisphere to a different color.

Metallic objects themselves also tend to be darker in reflection captures (full on black for mirror surfaces) so if this is a static mesh you might want to switch it to moveable so that it is not capturing the ship in the reflection.

Also just a piece of troubleshooting advice, you should be testing on a sphere with a simplified material in order to eliminate the asset itself as a source of the issue.

I apologize if any of this is just a rehash of what has been said already, I admit I didn’t read the whole thread…

3 Likes

OMG! Of all the suggestions this fixed it. I didn’t even know this was an option. I actually just unchecked the Lower Hemisphere is Solid Color option and it immediately made the entire mesh brighten up…

LowerHemisphere

The top is still a bit dark, but it’s a million times better than before. Epic’s default settings baffle me sometimes.

2 Likes

Real-time capture doesn’t seem to be an option in 4.16