Unable to download new purchased assets from marketplace.

Hey guys, i’ve a weird issue tonight, seems any assets i purchase from the market place are being stammped with the “unavailable” tag and im unable to download any of them.
Have tried logging in/out of the launcher, closing it/reopening it, cleaning out my VaultCache, even completely removing and re-installing the launcher.

nothing seems to be working.

Any assistance would be greatly appreciated.

I also have opened up a support ticket directly with EPIC but figured id check here as well.

1 Like

Your library can only hold 1000 assets. Any assets you buy after will not show up in your library and say unavailable. Its been an issue for awhile:(

1 Like

Guess i’ve hit that Limit then, Ill wait for a reply from EPIC and se what solutions they can offer me.

They will tell you to make another account and they can move a few hundred of your older assets to your second account. A few people have been complaining about this bug for the last year, not sure how long it will take to fix it :confused:

1 Like

Same issue as described here:
You will also find the solution in there, which Vathusmoure already described in short.

Because you have so many assets, perhaps you are also interested in some ideas people posted for having better support for having a lot of market place assets in launcher:

I still hope for some improvements and solution for 1.000 asset limit.

Hit the 1000 Limit cannot access Products purchased. Please resolve the 1000 asset limit.

1 Like

I agree,
please Epic resolve this problem.

1 Like

I may be approaching this limit soon, has this been resolved yet as it’s nearly been two years?

I have only 580 items in my marketplace vault. but the launcher only shows my 441 items in my vault… There’s a bunch I can’t download. I’ve tried very trick to get them to work, buying a new product, re-installing the epic launcer, etc. It’s just broken.

I was able to reproduce the problem: Browsing assets in the marketplace via web browser seems to be the problem. When Selecting for example a free asset in the browser it gives two options, Free and Add to Cart. Click on Free will open a pop up saying loading your order and then Thank you. and the buttons change to Open in Launcher and Write a Review although nothing was downloaded. When I click on Open in Launcher to Download it opens the asset in the Launcher but shows its unavailable.

Browser history does’t sync right to Launcher, and I can’t remove it from the Purchase history to start again via Launcher again.