Retargeted Metahuman Legs not moving when running (sliding on the floor)

Hi,
I have the following problem and hope that someone here can help me. I have retargeted the ThirdPersonCharacter (Manny) to my Metahuman and the following problem always happens:
The legs of the metahuman do not move and just slide across the ground.

I hope someone can help me with this.

Hello, Same Issue Here Found Something ???
It is working in IK Retargater But not in game play…

1 Like

Same issue here. Tried completely retargeting using IK rig and IK Retarget but it’s still not helping (Tried completely doing bone by bone too) still same issue. as soon as i change the skeleton - it all works. it is just the legs and feet that do not want to cooperate.

I have a similar problem when trying to retarget from mixamo to Quinn in UE5, feets are stuck to the ground but the legs are moving, here are some unresolved posts with what looks like the same issue.

1 Like

There’s also a solution in that threat with which however you lose the foot IK, meaning the feet will not be perfectly planted on a staircase for example: Retargeted Metahuman Player characters feet stick to/slide on ground

I also found this video tutorial on you tube which seems to solve even that issue:

And also this:

plus:
MetaHuman Foot IK - In UnrealEngine 5 - [OUTDATED] - YouTube (with the Foot IK fix)

Hope this helps :innocent:

2 Likes

Same here: most frustrating.
The retargetting seems to work ok, the resultant animations work correctly.

This happened in my project when I tried to use the old manequin animations on the new one… And it seems to be some problem with the IK thingy… Try deactivating the control rig node on the animation blueprint and see if it works. Like this:

9 Likes

The issue with feet sticking to the ground usually has the reason that you did not retarget the animations for the IK bones e.g. ik_foot_l, ik_foot_root… . If you retarget make sure that those move as well, and setup ik retarget chains for those bones:

7 Likes

Woop Woop!!! This worked!!!

This worked for me to! Remember to register this as an solution :slight_smile:

Thank you so much, the last part worked for me. This is what I did, after retargeting with IK I opened the newly created Animation Blueprint->control rig and changed the root in “Full body IK” from “pelvis” to “Animation root”.

That fixed the leg issue for me and its working beautifully now.

1 Like

To get this working you need to open up the retargeted animation blueprint, then in the anim graph, open the control rig node. Then you’re going to have to delete everything other than the red node on the far left. After that copy what I have put in and make sure everything is connected to the sequence.



9 Likes

This worked really well. Thank You for this kind of Solution. Please register this as a solution.

IK_Foot_l and IK_Foot_r are now named Foot_l and Foot_r, no need to create virtual bones for replacing them into FootTrace nodes.

1 Like

After looking everywhere and trying everything I could think of besides redoing all the Feet IK, I found this post, THANK YOU SO MUCH!

The four top nodes in the second image solved it for me. Many thanks.

I had same kind of issue when I was retargeting paragon animations to manny. Turned out to be (LeftFoot, RightFoot…)IK setting having FK translation mode defaulting to none in the IKRetargeter, which lead to feet being stuck to the ground. Changing it to Absolute (maybe globally scaled is better at some cases?) and re-exported animations and works like a charm.
See IK_UE4_Mannequin and RTG_UI4Manny_UE5Manny in Mannequin_UE4/Rigs if you need a point of reference.

1 Like

This seems to be the correct answer as you look here: Retargeting Animation Blueprints to MetaHumans in Unreal Engine | MetaHuman Creator Documentation
and scroll down

Does anybody know of a tutorial that gets this working in UE5.2? I’ve been trying several tutorials and answers in this post but so far nothing seems to be working. The best I can get is the feet will move, but they don’t interact properly with the environment and go through it.

Thank you for any help!

Hello, so I found a pretty solid workaround that enables IK under ALL circumstances (including for the UE4 Manny skeletons).

This is all in the Animation Blueprint:

  1. Create a variable of the ALPHA in the AnimGraph
  2. In the Event Graph, add another PIN to the SEQUENCE (by default, there are three)
  3. Add a BRANCH to that PIN.
  4. In the CONDITION (red node) of that BRANCH, use a LESS_THAN_EQUAL node, attaching the GroundSpeed variable (it is one of the default variables found to the left, nested in the Essential Movement Data column) to the upper PIN, and a float of 4 in the lower PIN.
  5. Drop the ALPHA variable as SET twice. For “TRUE”, set ALPHA as 1, for “FALSE”, set ALPHA as 0.

Basically what you’re doing is disabling IK when the character MOVES, and enable IK when the character does NOT MOVE.

Of course you can add an interpolation to smooth it out.