Retargeted Metahuman Player characters feet stick to/slide on ground

Hi, I have retargeted Quinn_Simple Player BP to Metahuman Player character in #UE5 through the new IK retargeting method, but even tho the retargeted animations all look fine if viewed on their own, somehow the feet of the character are stuck to/gliding on the ground while playing. I can’t figure out the reason. If anyone knows a solution, would be highly appreciated :pray: :innocent:

5 Likes

I’m having this issue as well with a different skeletal mesh - I believe the control rig IK is the culprit but I can’t figure out why it works fine with default skeletal meshes and not with one that has been retargeted.

Hey @jacobnvm I’ve already figured out the issue and solved the problem :grin:. You were on the right track. Within the copied animation Blueprint of ABP_Manny (which is the parent Animation Blueprint of ABP_Quinn) the Control Rig class is set to Mannequin basic Foot IK by default (see screenshot). And since the Metahumans don’t have Basic foot Ik and we could not therefore retarget by default (unless we make on for the Metahumans) it’s keeping the foot stuck. I set that parameter to FK_ControlRig and now everything works perfectly. I hope this helps :hugs:

5 Likes

Thanks for this! I think we are having slightly different issues, however. Your method would work to utilize the AnimBP while excluding the foot IK, and I’m trying to get the foot IK to work on a different mesh. I’ve actually figured out the problem - after retargeting, the ik_foot_l and ik_foot_r bones aren’t animating on the new mesh.

This is the same animation sequence on the mannequin

And this is on the new mesh. I’m going to try retargeting using the old method in 4.27 to see if that fixes it.

Same problem here. When retargeting animation packs from the ue4 to the ue5 mannequin, Foot IK is broken. Been stuck on this for a week.

The foot ik bones don’t seem to animate and stick to the ground while the rest of the animation works just fine.

This is definitely the issue, I played with multiple variations of the IK rig between the mannequin skeletal mesh and my custom mesh, but nothing would capture the IK bone movement when retargeting. I exported the assets to a 4.27 project, retargeted using the legacy method and everything worked fine.

Same here! Retargeting them in UE4, and migrating them over to UE5 fixes the issue - but using this method, it’s not possible to use the new UE5 mannequin since that can’t be used in UE4. Does nobody retarget animations in UE5 or why is no one else talking about this issue?

Maybe I’m just dumb, but whatever it is, I need a solution :-/

Before retargeting from UE4 to UE5, open the RTG_UE4Manny_UE5Manny, click on root bone and set translation mode to ‘globally scaled’ and give it another try.

2 Likes

This kinda worked! My only issue now is that the IK bones are retargeting with an offset, unsure if that’s to do with my mesh or not:

image

image

My temporary workaround while waiting for a real bug fix is to add an initial step in CR_Mannequin_BasicFootIK that will copy foot_l and foot_r translations into ik_foot_l and ik_foot_r then the rest of the sequence will work as intended.

3 Likes

Huge thanks for this, I’ve been banging my head against the wall for hours wondering why I can’t get my characters feet off the floor.

1 Like

you saved my life. thank you !!!

I solved it with Set Transform instead of Set Translation

1 Like

I love you thanks you so much for this I have been trying to figure this one out forever!!!

If you want a really quick workaround, bypass the Control Rig node in the Anim BP. Compile and save.