Poor Quality Shadows

I am using a source code build of unreal engine 4.5 but this problem has been occurring though all versions for me.

NOTE : i am using real-time shadows with a skylight if that makes any difference and the objects have cast inset shadow enabled


No matter how high the graphics settings are or how close i get the shadow quality is stupidly poor as iv’e pointed out in the picture below.

but on some other objects they seem to be reasonable?, bear in mind i’m using the same 3D modeling software (3ds max) and the same export/import methods?

The picture below is an example of good shadows.

Is there anyway to higher the quality of shadows no matter how pc-demanding it is. because this is the one problem that stands between cry-engine and unreal engine.

Is your house/building a static object? Static as in static selected instead of movable below the transform variables? If it is static then you will have to build the lighting to get accurate shadow results.

You need to increase the lightmap resolution for those meshes and the landscape. They may look ok on smaller meshes but you need more resolution for larger meshes.

As i said at the beginning “NOTE : i am using real-time shadows with a skylight if that makes any difference and the objects have cast inset shadow enabled”

If you are using dynamic lighting then check Settings > Engine Scalability Settings and make sure shadow quality is set to Epic.

I am using Real-time shadows, so increasing the lightmap resolution does nothing.

Where are these settings? i cant find them, are they in the editor or in the files?

Oh yes i found them and everything was set to max (epic)

Ok, do this then:

Go to World Settings and find Force No Precomputed Lighting. Enable that and rebuild the lights, and make sure the light source is set to Movable and see how it looks now. Your shadows do look like baked shadows so i’m not sure how that happened if you didnt build the lights yourself. But turning off static lighting with the setting i mentioned should make sure you are using dynamic lights.

If you’re using Dynamic lighting you’ll want to adjust the shadow bias in the details panel for the directional light. There is a trade-off here though. Lowering the shadow bias will give you artifacts if too low.

If you need sharper shadows for your static objects you may want to take a look at Ray Traced Distance Field Soft Shadows.


Yes, all those settings were already enabled, and they still looked like ■■■■. That was my problem i was wondering if i could increase the default real-time resolution or something.

Yes, Surprisingly enough iv’e already done all of that and that was my result in the picture.

They were already on all those settings.

Can you post a screenshot of your directional light’s properties?

Like i said its fine with small objects but not with buildings

You’ll need to reduce Shadow Filter Sharpen value, and as a side note, you dont want Min Roughness to be 1 if you want proper reflections from that light source on reflective surfaces.

This problem only really occurs on complex geometry none of the others so i honestly think its a bug in the unreal engine.

It is not a bug. Can you upload a sample project that replicates this issue please? Or some of the meshes that you see having this problem?

I cant, its not worth the hassle of replicating and uploading and all that , i just thought if anybody else had this issue that they could give me a fix, its the model anyway not the project or lighting, its when i import the model for some reason it down grades the lighting quality for that particular model but when i import a different model that’s got less complicated geometry, it has much much better shadow quality.