Download

WPO Landscape Flicker

Hello,

I’m using a black texture with a white circle in the middle as a mask to push some vertices up on the landscape on that circular area. But then all the area that is affected starts to flicker constantly. Am I missing something?

if using displacement, after the Lerp place a Min node in A with a constant 0.01 or 0.001 in B.
UE4.12 or up.

he’s using WPO, not Displacement :slight_smile:

Maximum: does it flicker when you zoom in/out or just standing still?
also curious why you use the VertexNormal if all you want is to push up

It flickers all the time even when I stand still.
When I don’t use vertexnormal the vertices get pulled towards a different direction. Like a 45 degree direction /

But,… did you tried the solution I suggested???

I’m not using displacement as you see in the material World Displacement and Tessellation multiplier slots are off.

Ref: “World Displacement works very much like World Position Offset, but it uses Tessellation vertices rather than the base vertices of the mesh”.

I know that problem when working with displacement tesellation and that fixed it. In this scenario probably works but if you dont want to try.

wpo_flick.jpg

multiply by a Vector3 with a value of 0,0,1 and they will only go up :slight_smile:

[MENTION=42883]Blackhole Bilbao[/MENTION], Basically what you are doing is that you tell “these” vertices to get pulled by 0.1 amount. Then you are telling it “the rest” of the vertices also should not be pulled by a value less than 0.1. That makes “all” vertices being pulled by 0.1 amount which is why you don’t see it flickering because “all” the verts are now equally pulled. I tried it anyway, but didn’t work.

Try using this as the mask and apply the material on a landscape. (don’t forget the UV of the mask should be the size of the landscape). If it was to work you should see a circle like in the OP.

Thanks. But still flickering so bad. :eek:

some of your landscape components seem to disappear so it seems it could be related to something else
in UDK there was a bug related to the collision component of the landscape, usually caused by moving it and doing Ctrl-z afterwards.
Try this: move your Landscape using the Gizmo in the Z axis. then in the properties panel, set the Z position of the landscape to 0 (or whatever you had before)

a850bd0593486302bc4223e2a439662889009fbe.jpeg
Tried with that same texture, but in my case I dont see any flicker. ¿?

@Chosker, Didn’t work. If it’s a bug, which it most certainly is, I guess I have to leave it here. :frowning:

[MENTION=42883]Blackhole Bilbao[/MENTION], Try a higher multiplier so we can actually see what it’s looking like. Also try plugging a 0.18 to BaseColor, it helps seeing the actual geometry better. Like this:

Edit: It only stops flickering when I have the landscape selected.

Its the same problem as I explained before. The same issue, I remember it.
That is also responded in the forum. Look for it.

Give me 1 minute to try that.

https://answers.unrealengine.com/questions/190390/flickering-material-on-landscape.html

-the Zfighting , find that there is no duplicate landscape.
-hidden the grid
-Place at 0,0,0.
-look scalebounds.

a2c3641a39d9bde9af1fa484fce196c5a7946abb.jpeg
I tried diferent landscapes and the problem is there when changed displace to 1000. The right one is right because is the near-clipping-plane.
¿Time to ask Mr.Alan Willard?

I’m quite sure that components disappearing is caused by your WPO expanding them beyond their bounds.

Happens with really small values as well. Or you meant that “any value causing this would be normal behavior” ?

[MENTION=42883]Blackhole Bilbao[/MENTION], Yeah say my hello to Alan if you could get in touch with him. Also mention SVOGI. :cool:

If you place the camera far far away from the landscape there is no problem.
Go to Landscape > Details > Negative ZBounds extension (under material)
ref:“Allows overriding the landscape bounds. This is usefull if you distord your landscape with world-position-offset…”
or
Positive Zbounds Extension

That solved it. Thank you! :slight_smile:
I guess there is no way to update the landscape collision after these vertices are moved no?