Why can't I access physical material on hit event

Hi there, does it work if you check the “Simulation Generates Hit Events” tick above the PhysMat slot in your component?


So I was working with hit events ob my bullets so I can make that material hit effect (hits wood, makes wood effect, hits metal makes metal effect, etc…)
The only way I managed to make hit recive the material was to apply the phys material into the material:


to access it:

but for my project it’s not reasonable to make a new material for every surface and most of the collision is going to be based on components like this:


to access it:

however, when I try to access the phys mat this way it just dosen’t work and gives an error:

what do I do to acsses phys mat this way?

no, it dosen’t

Ok, is the same setting checked in the component you are checking with? Are both set to Block each other’s collision ObjectType? If you need them to overlap try running this check with an OnComponent Begin Overlap event instead.

the setting is checked in both,

they block each others collision obj type

with overlap the same thing happens:/

ok I just found out what it is:

set this in both


I’m away from UE to replicate this but I believe the reason you can’t get it is that you’re grabbing the PhysMat right out of the HitResult, which may correspond to the root or actor and not the specific component you want to test against. From the OtherComponent (or the Hit Component) pin, can you drag out a Get Physical Material node? Then check for the Surface Type off that.

Oh great! Glad that worked! Disregard my last comment then :slight_smile: Cheers

cheers. :slight_smile:

a lot thank, that’s the correct solution!!!

FINALLY After 1 day … you saved me thank you