Why are my emmision lights varying in intensity when character or camera moves closer or away

[https://vimeo.com/768266611](https://Video of Issue)

Hey guys, new to unreal here:

I’m putting together a scene with some wall segments that have emissive materials on them, but for some reason the left side segments will grow brighter as if another set is turning on as i step closer, where as when i move to the right, the lights go down in intensity as if pieces of them are turning off.

The segments on both the right and left side are the same meshes with the same material on them however it only happens when i move to the left side.

I’ve turned off all post-process auto exposure as well and the problem persists. I’ve also removed all other lighting from the scene. The problem has something to do with the mesh placement or emission material from what i can tell but can’t seem to figure it out.

Does anyone know what’s happening here?

Looks like you’re using Lumen? Also only looks like the emissives are best represented in screenspace traces, so their actual contribution will vary depending on the camera angle.

Have you checked “Emissive Light Sources” on those meshes? That will keep them lingering around longer in the other, non-screenspace representations for Lumen. And if you can, use hardware raytracing with Lumen.

Yep! Using Lumen and have hardware raytracing on, the meshes also have emissive light sources checked - the odd thing is the same meshes with the same emissive material on the other side of the ship don’t experience the same variation in intensity it’s only when i cross halfway through the scene to the left, and once again towards the top left corner - it’s like some of them suddenly grow stronger or additional lights turn on. Which i feel like if it’s a GI issue it should happen when i approach the other meshes with the same material right?

Most likely the Eye Adaptation feature. It is on by default. When close to an emissive object, it will cause your scene to be overall brighter and more exposed so the auto-exposure will decrease to adjust. When you move farther away, the scene becomes dimmer so the exposure increases to balance the scene brightness. If this is not desired, simply turn off Eye Adaptation / Auto Exposure.