When adding objects, they turn gray.

When i go to add an object, the object appears normal in the content browser… but when i go to drag it in, it changes color like it has no shaders… what do i do?


be sure that the material on it is the correct one. Maybe your mesh has the default grid on it.

Is your lighting in the viewport set to LIT?

Yes it is. But still… i get this: Imgur: The magic of the Internet

No, it actually loads no material what so ever. So i tried to add a material and it turns gray… However, when i used it after this it magically began working.

perhaps this is just noob-lcuk

perhaps it is just one of those things that randomly effect random people… but irrelevant, thank you for your help

haha, it happens sometimes, so fix that, you just need to “update” the material of the mesh/actor

No problem, ask and the community will help. Pls mark as resolved, so ppl know you have solved the problem, thanks and good luck

Oh yes… im sorry, im not used to doing that yet :stuck_out_tongue: Thanks a lot.