Warning CreateExport: Failed to load Outer for resource ... for many blueprints


we just run into a problem of one of my team mates machine. On that machine we get the warning “Warning CreateExport: Failed to load Outer for resource …” a lot (<800) in many blueprints. And after that the editor is crashing most times. I copied his project folder over to my machine and there is everything running fine. We reinstalled the launcher and unreal as well as completely deleted and force synced the whole project from P4. But nothing is helping. On all other team machines in our team the project is running fine.

After deleting and resynching the whole project I get once the error:
“Failed to import ‘C:/Program Files (x86)/Epic Games/4.12/FeaturePacks/StarterContent.upack’. Failed to create asset ‘/Game/StarterContent’”
But unreal is installed with starter content.

One artist is completely blocked atm. please help.



We were able to fix the problem by deleting the unreal cache folder.

The unreal cache folder is located here:

We still have no idea what caused the problem.


The problem showed up again and we found out it is enough to delete the %userprofile%\AppData\Local\UnrealEngine\4.12 folder.


I just updated to 4.13.2. I am getting the same error but on a much smaller test project based the first person shooter demo. I tried deleting the 4.13 folder as you suggested to no avail.

I deleted the 4.14 and the Common directory. That fixed it.


Has anyone tried this in a Mac system?

Worked perfectly for me. Thank you!

I am getting to happen in 4.18.1 a lot for some reason. Not sure what is causing the data corruption but it is nasty. The editor won’t load and the Blueprint class breaks. I thought it might be caused by having 4.17 and 4.18 open at the same time with the same asset being used by two different projects.

I am getting the exact same error with 4.19.2. I purchased a new laptop so that I could work on the project while I am traveling, as well as show off what we have completed so far to potential investors and publishers. Today, I downloaded all of the new files from our Perforce server to my laptop after checking everything in on my desktop and I started getting this same error on the laptop.

I have tried all of the suggestions to fix the issue, but none of them work. Any additional help with this would be most appreciated.

You can try the following (make a backup of your project folder before or have it in source control). This helped me with UE 4.19.2:

  1. Delete all derived folders & files inside the Unreal project folder (leave only Config, Content & Source folders, and .uproject file).
  2. Re-open Unreal - from the launcher or .uproject.
  3. Generate your IDE project files (Win: via Explorer context menu; Mac: Via Unreal)


1 Like

SO i just ran into this problem in the past week or so, we are using git hub and doing all of our source control through it.
We are also using git LFS.
I played around with a couple of different things to get past this error, including the help ideas suggested above. I can’t give a concrete step by step solution to the problem. But I can give the things i did to ultimately get past this problem.

  • Delete the %userprofile%\AppData\Local\UnrealEngine (as suggested by )
  • Delete the internal files like Timdhoffmann suggested (I deleted only the Saved and Intermediate folders)
  • Run the following git command

git filter-branch --force
–index-filter ‘git rm --cached --ignore-unmatch Content/* Config/* Build/* Import/*’ --prune-empty
–tag-name-filter cat – --all

At this point i repulled my repo, and things started to work.

I believe that this essentially purges all the references within your git delta history (i could be wrong if anyone can correct). SO THE WARNING HERE is if you don’t want to lose all of those references within your git history don’t do this.
This effects the references in all of the repo’s branches.

The rabbit hole I went down to solve this problem:

I’m having the same issue, for me the problem was that the level I was loading had previously contained a blueprint that no longer existed.

1 Like

And how did you fix that IlllIl ?

Happened to me with 4.23.1 rather frequently when you delete referenced content, this even for a few files can take extensively long, making me quit the editor through the windows task manager. Deleting the cache folders as outlined above fixed it for the most parts, some errors remain though …

Update,I figured out a way to resolve it, explained here Failed to load Outer for resource on opening a persistent level - Blueprint Visual Scripting - Unreal Engine Forums

Hi. how did you fix that ?

For me the Load Errors appeared when replacing the child class of a ChildActorComponent in a BP. The BP was already placed in multiple sublevels.

Solved by deleting the ChildActorComponent and recreating it, using the newly created child class.

Version: 4.25.3

Hi, All,
I recently got the same issue.
The problem for me was that the level I was loading had previously contained a blueprint that been force deleted.
As I know the only one way to solve it is recreate a dummy blueprint with same name of unloaded blueprints.
Could use reference viewer (right click on content folder) to locate the missing blue print.


Hello! I am having this same issue. I have done all of the suggestions including trying to migrate my files. I still have no solution. Unreal is telling me that it can’t reach a file i deleted and although i deleted and it can’t find it, it is still applying its affects. Has anyone found an alternative solution?

yeah having this issue with UE5


Bless you.