Warning CreateExport: Failed to load Outer for resource ... for many blueprints

Possible solution below.

Problem: At least in my case, this was because the editor was not recognizing a .cpp file that was serving as the parent class of a BP. Notably, the .cpp file existed on both Helix Core (Perforce/P4V) as well as my local machine.

Solution:

  1. Open editor (yields CreateExport warning)
  2. Open a .cpp file
  3. Close editor
  4. Build from the IDE (e.g., in VS Community, Debug → Start Without Debugging)
    Should be solved… I also opened the problem level and saved for good measure, but I don’t think that matters.
3 Likes


I had the same issue with a marketplace content pack. I tried all above steps and then some. Then I enabled “force all dependencies to recompile” in project settings / engine / blueprint project settings and … voila, no more errors. I also had many corrupted blueprints. Hope this helps.

Well I had the problem again, and opening and saving the problem level did in fact matter.

1 Like

Got the same problem, fixed it deleting “binaries” folder in project folder
"Document>Unreal Projects>ProjectName
It will rebuild everything

1 Like

Too bad, doesn’t exist anymore in UE5.0.3

1 Like

Still seeing the problem in UE5.0.3.

  1. I just followed through the Programming Quick Start for Windows exactly, though Live Coding was enabled, so built via Ctrl-Alt-F11 in the editor rather than in VS 2019.
  2. Saved All and quit
  3. Later re-opened the project
  4. Got the same error as OP (except for the Mesh component of the FloatingActor the tutorial has you create).

I resolved the error using xKuusi’s steps above, and it does not recur. Also thankfully UE didn’t make me have to re-place an instance of the Actor.

Seems like it could be related to Live Coding compilation? I realize that only makes sense back to v4.22 though…

I repeated the above with a second brand new C++ Actor subclass, built with Live Coding, placed an instance of it it in the level, and got the same error for that Actor instance after re-opening the project.

I then disabled Live Coding in Editor Preferences, created a third new C++ Actor subclass, built in VS 2019, placed an instance, and did not see the error when re-opening.

Need to explore the output of Live Coding more in detail to see what the difference might be. The good news is that you can still use Live Coding, just so long as you eventually do a build without it.

1 Like

Here’s a fix that I randomly stumbled upon while trying to solve this issue:

  1. Copy the current level that has the bugged export into another directory.
  2. Delete the original level file and change the default level in Project Settings to the new one.
  3. Restart the editor.

This fixed my project on 5.0

2 Likes

I came up the same error, and my root cause is, I changed the Config/Default<Name>.ini file, and added some redirects to it!
After I delete these redirects, these errors were gone.

I can verify @Cycl0pso’s post works. These strange steps, in this order also worked for me. Do it all the level copying inside the editor and don’t do a move, or it might break. I actually was never able to have the same level name again in the same location without it getting those errors again…

I also get this error, but the solution suggested will never work for my projects.

What happens is that I use a package that use the PhysX Vehicles plugin, that was depreciated. ( How to Convert PhysX Vehicles to Chaos in Unreal Engine | Unreal Engine 5.0 Documentation)

In this case I guess I will have to convert Vehicle blueprints, to work with “chaos” - or even workout how to make the package work as other working UE5 Vehicles - say those that came with the city sample / City Sample Vehicles in Props - UE Marketplace (unrealengine.com).

I am rather sure I did not get a warning for this plugin, when running the conversion - so I spent some hours to figure out why i got these stange messages.

This is how the same AB_BoxTruck blueprint looks in UE4.26 and UE5.1

As you can see the Parent Class is missing in UE5. Same thing can hapen when your C++ code breaks, but apparently UE4/5 is logging this in a very cryptic way:
“CreateExport: Failed to load Outer for resource ‘AnimGraph’: AnimBlueprintGeneratedClass /Game/VehicleVarietyPack/Skeletons/BOX-A/AB_BoxTruck_A.AB_BoxTruck_A_C”

It would make much more sense to me, it I could simply get a list of blueprints that are missing theier parent class… but it seems like that fact is missing completely from the message log??

My 2nd observation on this problem

What I fear even more is that it looks like some are having local issues. That is one one computer the projects open, while it wont on an other. And the problem may not be visible until you try to package the project…

Made me think about the fact that I followed some tutorial, suggesting that you can save a lot of harddrive space - you can open the options and remove some features that you don’t use… but I guess that you may run into problemes if you want to run or upgrade a project that depends on some of this “optional” stuff? ( (181) SMALLER Unreal Engine Installs! Recover 20+ GB - YouTube

So I suggest that you are a bit careful when removing engine features - maybe I an wrong, I hope so. :smile:

If you have built your Blueprint using a C++ class or subclass, it may not be able to find the Class, which causes the Issue.

To Fix I did the following using VS2022:

  1. Recompile with Live Coding
    This caused the C++ Class to reappear in the Folder.

  2. Close UE

  3. Open Visual Studio and use the Debugger. I had it set to “Development”

  4. UE5 Opened up when I clicked on the VS2022 Debugger, without an Error Message and I was able to edit and use the affected Blueprint like normal.

1 Like

I just had the same issue in UE5.2.
The solution for me was that I had a TSoftclassOf<> via a config file that I guess was being loaded (or attempted to at least) from a plugin before it was ready.
Swapped it to use a TSoftClassPtr<> and it worked perfectly.

had a similar issue migrated a different project in my main project it didn’t workout as planned so deleted it from file explorer before deleting it from my level

but it worked by deleting the config file from the project

I just had that issue after reparenting blueprints. The only solution for me was to open the level in a backup, delete the reparented blueprints, copy the map to the project and reinsert them.