Download

VR Template Physics Issue 4.27

oculus quest 2

amd 5950x + 5700xt

ue5 even worse

ue426 ok, but vr pawn - unusable garbage =(

Is it a Chaos Physics thing? iirc Chaos is on by default in 4.27 but not in 4.26. You could try enabling Chaos in 4.26 and see if you get the same bugs.

more to the point.
Is sub stepping on?

And I’ll have to test but if Chaos is still performing like it was in .26 just turn it off or go back to something like .25 with physx…

it is default vr template

without chaos nothing works

Well yea. You either need to jump through hoops to go back to phys x via settings.
Or you have to custom build a branch of .27 with phisx instead.

No one said it would be easy… going to run a performance test on ragdolls right now just to see how bad it is…

Actually, Chaos isn’t performing horribly like it did.
What does perform horribly is the rendering engine.
You’d think I had ray trace on or something given it drops down to 10fps with 1500 simulating engine cubes.

Removing the shadow casting off directional light allows to bench just the engine on ragdolls and boxes.

As far as stacking boxes, it works with default engine cube and no VR - could it be the template that’s bad?

lol, literally every one sad that!

INDUSTRIAL STANDARD it’s easy and ready to work! - they sad it so loud, so every one start to believe it…

adobe, autodesk - it’s just ■■■■, full of bags…

and EG on their side…

25Gb of source code for what?
unlimited money for what?

meanwhile Godot code base weights less than 1Gb and everything could be bugfixed within a week, by endless contributors from around the world (and laucher works on Linux btw -_- )

sorry for triggering…

I share the sentiment almost entirely.

That doesn’t mean that the VR template was just neglected and has some basic missing stuff to it potentially - like sub step settings or bad collision settings on the boxes it uses.
Project Settings > Engine > Physics.

Physics is also tied to the running frame rate unless you do enable sub-stepping. And because the rendering engine seemed to be performing like trash for me - 1000 simulating engine boxes, 16fps at 2k??? - it could very well be that in VR (rendering 2 eyes) you are running into timing issues.

oh, i get it now

really interesting

but in default scene we have only 8 cubes :slight_smile:

But you are rendering 2 of the exact same scene. One per eye.

I have no frame of reference as to what Ms count you should expect. But my guess is that the FPS is so low as to cause problems.
And/or the template is just badly setup because it wasn’t tested.
(The engine has no quality assurance team. They rely on people like you and then ignore all their feedback or bug reports :slight_smile: )

framerate is ok actually

Thanks for the report. To clarify since there was some confusion in the thread. Chaos is not default in 4.27, PhysX is.

It looks like you’re using the Quest 2 with Oculus Link on Windows?

Because Facebook hates FLOSS (no Linux support for Quest 2)
and there is still no EG Launcher for Linux …

so yeah… i have to use it under windows, 11 in my case

instead of cable, I’m using a free and open source Virtual Desktop (or a weird implementation from Oculus - Air Link) alternative called ALVR + SteamVR, with 5Ghz wi-fi router, with perfect connection, without any noise (live in suburb)

Thanks for the extra info!

The XR Team is digging into this problem - it’s not necessarily a physics-caused issue. I’ll update the thread as we learn more.

3 Likes

afaik Chaos is still off in 4.27 ( there is a new 4.27Chaos build available with it enabled)

So what are we saying here?

Am I getting no stacking problems because I’m using chaos and if I were to revert to physx boxes (that have stacked for the past 12 years) won’t stack anymore?

Doubt it.

On the plus side it’s good to know that you don’t necessarily jump hoops to get physX back just yet.
(But building from source is probably worth it anyway.)

That’s far more likely at this point.