Very hard shadows on some Static Meshes

I have a problem regarding some static meshes. They seem to have no regular shadow or light falloff, but instead a sharp edge for the shadow. They are created in Blender and they use the exact same export settings as many other meshes, which have no problems at all.

I’ve tried several things to solve this, but it does not seem to be connected to a material or normal map issue. I’ve also tried to increase the light map, tried recomputed tangents and normals, but nothing works. Does anybody know what causes this strange shadow casting on the mesh and how to solve this?

Increased the lightmass resolution of the table, where the shadow is being casted? Maybe it is the UV channel too, try to import the mesh again to generate a new UV channel

Thanks but I’ve already tried that. Does not change anything. Here is another screenshot from a different static mesh. They all have the same issue, but other meshes are working normally.

looks like the UV channel

How can I fix it? Generate Lightmap UV option when importing is checked by default. When I uncheck it, it still has the same issue.


try this: Unreal - 3Ds Max - Maya - Blender - Lightmap Overlapping Fix - YouTube

I’ve tried it, but the issue is still the same.

sorry to hear that…

well, tried to change the mesh to movable and rebuild the lights to see if anything changes?

The mesh is already movable. The lights are 100% dynamic, nothing to build there :wink:

Ok here is the solution: even if you use a normal map, you got the set the shading for large flat surfaces to flat inside your 3d program

1 Like

I know this thread is many years old, but I was also having the problem of some static meshes having very dark surfaces:

And inspired by this topic I tried using Flat Shading instead of Smoothing, but that was not the solution (and made the models look bad as expected). Then I reviewed my maps and noticed that due to a bug in my material, Ambient Occlusion was being set to 0.

As soon as I correctly used the AO map texture in the material, things got back to normal. I.e. make sure AO is not set to 0!