Unreal Engine 5 crashes on Start up

Error Message:

LoginId: removed for reasons
EpicAccountId: removed for reasons

Assertion failed: NumBytes == Strings.Num() [File:D:/build/++UE5/Sync/Engine/Source/Runtime/Core/Private/UObject/UnrealNames.cpp] [Line: 3357] UnrealEditor_Core!LoadSeparatedNameBatchInShardOrder() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\UObject\UnrealNames.cpp:3357] UnrealEditor_Core!FNameBatchLoader::Load() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\UObject\UnrealNames.cpp:3493] UnrealEditor_Core!LoadNameBatch() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\UObject\UnrealNames.cpp:3502] UnrealEditor_AssetRegistry!FAssetRegistryReader::FAssetRegistryReader() [D:\build++UE5\Sync\Engine\Source\Runtime\AssetRegistry\Private\AssetRegistryArchive.cpp:140] UnrealEditor_AssetRegistry!FAssetDataGatherer::Run() [D:\build++UE5\Sync\Engine\Source\Runtime\AssetRegistry\Private\AssetDataGatherer.cpp:525] UnrealEditor_Core!FRunnableThreadWin::Run() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:146]

Specs:
AMD Ryzen 5 2600X
Radeon RX 580
16 GB of DDR4 Ram

It was running fine for the past few days, but yesterday it just decided to start crashing when I first start it. I tried reinstalling it before to see if it would fix it, but it just gave me the same error.
Any Ideas on how to fix it?

5 Likes

Hi, I have the exact similar issue as Justin here. May I know if there is a solution? Now I could not open my levels done in Unreal 5 anymore, this is quite serious. Hope there is some help.

I tried uninstalling, reinstalling unreal5, uninstalling, reinstalling to another folder and deleted all memory temporary files on windows, and it still doesn’t work. I don’t understand why a simple reinstallation cannot fix this “back to default” for unreal engine 5. Why is the realy problem here?

2 Likes

I still could not figure out the issue. I been looking for a solution forever, and I still can’t find anything sadly.

Did you manage to fix it?
Getting the same error here. Can’t open my project anymore…

1 Like

Hi guys, for me worked to delete the folder:
C:\Users\youruser\AppData\Local\UnrealEngine\5.0

Hope it helps.

2 Likes

I was suffering from this up until recently, this is how I solved it…

This error comes from a corrupted CachedAssetRegistry.bin file. Reinstalling it does not fix the file.

To fix this, you are going to want to go to file location C:\Users\username\AppData\Local\UnrealEngine\5.0\Intermediate - Locate the file named CachedAssetRegistry.bin and delete it. After deleting it, you should be able to launch

10 Likes

Thank you very much, my problem is solved :slight_smile:

1 Like

definetly the fix. THANKS!

This works also for others on 4.26 or 4.27 which i tested… So if some one googles and search for this ERROR: /Engine/Source/Runtime/AssetRegistry/Private/PathTree.cpp]
TRY THIS!

1 Like

there is an awesome amazing side effect that has happened twice for me! :smiley: ALL OF MY BLUEPRINTS GOT DELETED

I’ve got the same crash issue here. After a bit of fiddling, I figured that it’s caused by the Quixel Bridge plug-in. Deleting the CachedAssetRegistry.bin seems to work for me ONLY if I also uninstall Bridge through the Epic Games Launcher – which means I can’t use Bridge.

Oddly enough I could use Bridge for a day after installing UE5 before this started happening.

Does anyone else have the same issue by any chance? I’d really like to keep using Bridge but I can’t find a way around this.

2 Likes

Hello
I am completely new to UE. I just installed UE5 and when I open the first project, it crashes after a few seconds. I get the following log error
Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x0000000000000018

nvwgf2umx
nvwgf2umx
nvwgf2umx
nvwgf2umx
nvwgf2umx
D3D12Core
D3D12Core
dxgi
dxgi
dxgi
dxgi
dxgi
dxgi
UnrealEditor_D3D12RHI
UnrealEditor_D3D12RHI
UnrealEditor_D3D12RHI
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_RHI
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_RenderCore
UnrealEditor_Core
UnrealEditor_Core
kernel32
ntdll

I deleted the CachedAssetRegistry.bin but its still crashing.
Could someone help me with this issue?

1 Like

I deleted the folder. It lasted a few seconds more and then i got a different error log
Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffffffffffff

I think i found the solution! I restored the Global Settings from the Nvidia Control Panel to default and it does not crash anymore !

Exactly the same issue here!

I also have this same problem. i want to reinstall Epic games launcher
, then verify Unreal engine 5. Hope it works

Hi, i haved the same problem. After some sessions on UE5, the soft become crashed without error detail. Then i noticed that when i removed the Bridge folder in the plug-in folder of UE5, the soft started. So for correct the problem :

  1. Launch your project Unreal in UE5 (without Bridge folder in UE5 plug-in folder)
  2. Open the plug-in window in UE5 interface and enable “Web Authentification Plug-in” and “Web Browser”
  3. Close and add Bridge folder in UE5 plug-in folder
  4. Launch your project
  5. Enjoy ! :wink:
4 Likes

hi, having the same issue, any solutions?

This worked for me!!! Thank you soo much!!!

Thanks, This worked for me and saved me a bunch of time, I am sure!