Download

Unreal Engine 4.27 Released!

Unreal Engine 4.27 brings features and updates for all creators offering a production ready feature set for Virtual Production and newly added functionality for AEC and manufacturing users which continues to put Unreal Engine at the forefront of technology. Unreal Engine 4.27 provides the right tools and workflows to get the job done.

GPU Lightmass provides high-speed baking for same day lighting and layout changes and Multi-GPU support enables wider camera and simultaneous dual camera shooting scenarios for In Camera VFX. Production ready pixel-streaming gives our users greater creative freedom and more choice over how to deploy Unreal Engine. RAD Game Tools has joined Epic Games, and the Oodle Compression Suite and Bink Video are now included for all Unreal Engine developers.

Unreal Engine 4.27 will be compatible with UE5 when it becomes available next year.

See the full release notes here and drop your feedback below!

Unreal Engine 4.27 Feature Highlights

KNOWN ISSUES
For a complete listing of known issues affecting Unreal Engine 4.27, please see the Unreal Engine Public Issue Tracker .

If you discover new issues with this release, please report them using the guidelines in the link: How to Report a Bug .

12 Likes

Fantastic! Great news!

Was looking for the Live Link VCAM app on the Apple App store. Couldn’t find it. any word on when it will be released? Or will it be available through testflight?

1 Like

:+1:

Is this news, I’ve been living under a rock or what? Not surprising really, but thanks for the date-ish!

1 Like

GPULM and Path Tracing are still exploding on my 6800XT. It used to work in 4.26. Now just pressing Build Lighting or changing the view mode to Path Tracing results in a 1-2 second hang and DXGI_ERROR_DEVICE_HUNG.

Hi UntamedLoli It could be due to GPU timeout. Have a look at this artice. How to Use the Movie Render Queue for High-Quality Renders | Unreal Engine Documentation maybe it will help?

GPU lightmass doesn’t appear to be generating any volumetric lightmap at all for me… Turning on the VLM visualiser after a bake with default settings shows absolutely nothing, not even the usual probe grid.

Edit: Seems to have miraculously fixed itself. No idea what the issue was.

how can we use the oodle texture compression? i don’t see it under the compression settings tab/

I tried changing it before from a discord recommendation in regard to Substance Painter. I tried it again and it had zero effect. Even disabling it (TdrLevel=0) did nothing. I was restarting between changes. The crash dump doesn’t seem to be changing any either.

It doesn’t seem to be following the windows timeout period of 2 seconds when it can happen less than a second after pressing the button.

/e

Just to be clear, windows isn’t giving me a driver crash. UE4 is what’s crashing.

The HUNG status is given by the driver as response to Windows and that goes through DX11/12 to UE4. Increasing the TDR value (the timeout) would mean keep waiting for longer operations. Are the RX6800XT driver updated to the latest one?

Hurrai - can’t wait to test 4.27.0. …Downloading
In the mean time reading the release notes.
Note: the link from the VR documentation page VR Template | Unreal Engine Documentation to the input mapping for XR is broken (404) https://docs.unrealengine.com/4.27/en-US/SharingAndReleasing/XRDevelopment/Openxr/input_with_openxr

edit: any idea when the Twinmotion content plugin will be available for 4.27?
edit2: In the release notes it states “Users can now also tap Movie Render Queue to render from multiple cameras as a batch process, without having to go through complicated Sequencer setups” → Where to find this option in the MRQ? No info in the documentation either.

They are the latest, 21.8.1. I started on 21.6.1 and tried the UE5EA drivers for fun. UE5-main has the same issues as far as I can tell.

Any reason for a game developer to upgrade from 4.26?

4.27 -

All my post process materials stopped working. - Ran through everything I could find something changed in how full screen effects are handed so all my outline pp stopped working along with full screen effects. Try fixing it via the material, volume, project settings, nothing seems to work.

Exponential height fog will not change colors via blueprint settings. - FIXED

NEW - A bunch of levels needed to be opened and re-saved as they producing a new “warning message about not being able to attach to another actor” once opened and re-saved these warnings disappeared one by one. – FIXED

BUG - All actor ? documentation in the editor is broken giving “missing template error” find any actor in the place actor menu and find a ? click on it opens a webpage with the previous mentioned error.

Overall everything has been going smoothly with my upgrade from 4.26.2.

congrats on another splendid achievment ue team! On a side note, anyone know how oodle works? my build size is slightly bigger than .26, expected a more drastic difference :smiley: thanks!

I dont know why, But when I enable in 4.27 Mobile Ambient Occlusion, all Objects in my level didnt get rendered.

I have a question… is the GPU Lightmass light limit per sublevel? Or per everything loaded into the current level at the same time?