Download

Unreal Engine 4.27 Released!

In 4.27 the 256 limit of lights has been removed for both GPULM and Path Tracer. You can practically have infinite number of lights (as long as they are not too close together - ‘Light Grid’ is used to manage the lights and you can’t have too many lights in a single cell of the grid)

not sure its working… i have some spot lights that simply arent casting any light at all in the bake… its a dense scene… but still…

In fact any new light i create also doesnt add to the bake… seems like light limits are still in place.

Screenshot shows on the left the bake… on the right as a dynamic light.

From release notes:

Oodle Texture compression are the fastest and highest-quality encoders for block-compressed BC1-BC7 textures. Oodle Texture’s Rate Distortion Optimization (RDO) encoders can make high visual quality encodings that are 2 to 3 times smaller than the non-RDO encoders!

Oodle Texture compression is enabled by default in Unreal Engine and RDO encoding can be enabled in the Project Settings (RDO encoding is off by default).

I am interested in the “Unreal Engine as a Library”, but other than a couple of lines in the release notes I cannot find any info, can someone point me into the right direction?

Thanks

2 Likes

You find the UE Lib API in the source code in this folder: “/Engine/Source/Runtime/UELibrary”

2 Likes

I saw that foliage/instanced static meshes now have the option to Evaluate World Position Offset for raytracing which seems to be the same implementation from the Nvidia build. This workaround while being reasonable in some scenarios isn’t a good solution especially because it really isn’t all that accurate and as a result leaves you with the same issues that you’d get without evaluating WPO and in some cases can make it look even worse by completely breaking things like AO.

I get that the goal here was to save on performance but realistically I’d assume most applications of this are for non real-time uses (at least for me they are) and so performance budgets are not as tight. It would be great to just to enable perfect WPO evaluation just like you do with individual static meshes. Circumventing this by placing all your foliage manually so you can get perfect WPO is irritating and a chaotic workflow.

UE4.27 have:

Online Subsystem EOS Plugin

This is exposed to Blueprints or only work on C++ ?

Thanks!

I was able to enable it and I even have connection statistics displayed in dev.epicgames.com
But I still can’t manage it through blueprints like in the SDK Steam system.
And also I’m going crazy for the lack of at least some documentation for the plugin.
At the moment, I learned a lot more from the xsolla sdk ( login & account system) documentation than in the documentation on dev.epicgames.com

This is a great release, thank you guys! I really appreciate the Alembic groom update :grinning:

A feature request, in the groome settings can we get the ability to animate the gravity for a quick easy way to create groome hair blowing in the wind. Thanks!

My engine has errors in the shipped project, because not everything is the same as in the editor (for example, the main character is missing the head shadow, complex actors in the scene do not disappear when necessary and disappear when not necessary). Previous version 4.26 works fine. Maybe it’s just me this happens. But I think the current release is not suitable for distribution.

C++ Only.

There may be a problem with Live Link Face. The mouth of the character doesn’t seem to animate as reliably, even after doing calibration. I’ve only tried it with 4.26 and 5.0 so far, was something changed in the unreal end so this would only work well with 4.27?

I was trying to finish some animations in 4.26 using the new Live Link Face today and it seemed sometimes the mouth was just not moving as much. Even if you compared the mouth on my ipad screen with the character in unreal. It seems to be missing some of the smaller movements.

The other thing I noticed is if I DELETE my calibration the mouth doesn’t hang open slightly like it used to with the old version, so something seems to have changed.

I’m still not sure if I’m imagining it or not, so here’s a sample. That was done with the NEW live link face and UE5.0

And here is a sample done with the OLD Live Link Face, UE4.26 and manual calibration.

What do you think? Am I imagining it or is the mouth a little off?

Were there other changes that make this version only work well with 4.27? I am getting ready to try that. Would love to know if anyone else has noticed a change.

Spline Meshes still dont cast RT shadows and invisible in RT reflections.
New foliage setting “Evaluate World Position Offset” literally do nothing.
“Volumetric Translucent Shadows” still dont work with RT shadows.
Still no RT GI in RT reflections.

Im disappointed.

1 Like

Plus the hair and fur system isn’t visible in RT reflections at all. And RT translucency still breaks so many things as I’ve shown in the 4.27 preview thread. That’s a pretty long list of unsupported features given it’s deemed “production ready”.

1 Like

To get foliage to evaluate WPO you need to set r.RayTracing.Geometry.InstancedStaticMeshes.EvaluateWPO to 1 because by default its on 0, no idea why its not on -1 by default. Don’t get your hopes up though, it completely breaks AO and shadows are still inaccurate.

2 Likes

Thanks. This is better than nothing but still “dirty hack”. Not a solution. Shadows are not static now
but mesh still have ugly flicking double self shadows on leaves.


1 Like

Hello,

we are looking on how to embed UE4 as library but it seems that the sample is not embedded according to the page here.

Building Unreal Engine as a Library | Unreal Engine Documentation

1 Like

Hi, have you sovled your problem? And can i ask you a question , hava you finished the first step that successfully built the UELibrary and generated UE4Editor-UELibrary.dll according to the page here ,https://docs.unrealengine.com/4.27/en-US/SharingAndReleasing/Buildasalibrary/? I tried to add the code in the page mentioned above to my project’s *.Target.cs file, to be specific i add the code to UE4Editor.Target.cs file because i choose the Development Editor configuration on Win64. but when i build there are lots of error. i also tried to create my project by UE4 engine and add the code to my myProject.arget.cs, None of these approaches can implement the new feature.

Unfortunately I could not manage to proceed on this front.

Has anybody noticed that 4.27 branch can’t compile? I’ve tried downloading the latest, I’ve updated my visual studio 2019 and installed all the nuget packages, nothing has worked. Check this thread: