UE5 Video Media player not working properly

Look for Shutter Encoder, its free and it worked for me, running Windows 10.

1 Like

This worked for me too, thank you for your suggestion.

I hope to see full working solution for MP4 soon but… ProRes is working just fine.

Thank You, saved me more days/weeks of frustration.

1 Like

Does this also work in Windows?

And you have the otherwise broken blueprint compüoments working like ‘seek’ and ‘playrate’?

This bug is still present in UE 5.0.1 and the mentioned (free) fix with using Shutter Encoder for encoding to AppleRes works fine.

1 Like

I’ve been struggling the same playback/render issue but finally solved just now!

My case:

  • UE5 EA2
  • RTX 3080 / 96GB RAM
  • Five Media Players playing mp4 videos (later switched to image sequences)
  • MRQ render necessary

My problems:

  • Either video (mp4) playback speed was about 100 times faster on rendering, or
  • playback (image sequence source) completely stopped on rendering

What I tried (solution found on this thread):

  • RHI to Default, DX11, DX12, Vulcun, none worked
  • ProRes plugin enabled and/or video transcoded to prores: none worked

Final solution to my case:

Now finally MRQ renders media playback (image sequence source) correctly. Yeah!


YOU ARE AMAZING! This worked for me just fine. I spent over an hour trying to solve the issue and tried the apple media trick to no avail, but this! Im doing this just to Rick Roll my class, THANK YOU SO MUCH!

Switch to Direrctx11 and all solved.

Hi. May I ask to which plugin you are referring? Thanks.

Has someone figured out how to play the video sound with attenuation and falloff distance set (the sound getting more silent depending how far away you stand from the source)?

No. This is not a good answer to the issue. :smiley: Doing this will cause a lot of other issues with any of the new tech in engine. I highly recommend you do NOT do this. Use the other solutions as posted by others.

Hello there,

I’m trying to create the same thing. I changed the projet settings and change the RHI by default. I can see now the video on sequencer but i can’t apply the video texture on my tv. it stays blank. I don’t know why. Thx for your help !

PS : I can see the video running in viewport but not when i play the level.

Thanks, this works perfectly.

You changed to RHI 11? If your using UE5, I would highly not recommend this. Take one of the other paths to correct it or wait until 5.1 which is when I believe the fix is coming for this.

Few weeks ago the Electra player worked perfectly, now after the recent Unreal update it won’t anymore (plays video preview without audio and video doesn’t show in game). Is there anyone else who encountered this problem?

1 Like

does not work for me, changing to direct x 11 is working but no nanite

Yeh It doesn’t have audio to… any fixes yet?

have you guys tried this plugin called Electra Player?. try to enabled that plugin for media player. It works for dx12 that way too. I had saw some commented on a person YouTube video tutorial on fix media player for ue5 dx12.


It is great ! It solved my problem, thanks a lot. :kissing_heart: