UE5 Video Media player not working properly

Video player only playing sound, the video is blank, no matter the format. it works well in ue4. Here’s a link to a video showing this.

any idea how to fix this problem?

2 Likes

Sadly, but it’s UE5 Preview Bug. I have tried to use MP, same problem. I sent bug report. You need to do that too.

We too are experiencing this. This is a pretty substantial issue. This has been happening since EA2 and is still occurring on P2. You can convert to Webm, however playing those seems unstable and its hit or miss for the engine crashing in editor and package builds. You can usually get 1 to play then the next one you play crashes.

1 Like

So it’s worse problem than I thought…

1 Like

We are talking about it in Main chat here. You can add your comments there, we might be able to get a better answer on this. :slight_smile:

1 Like

I got a plugin off the marketplace that adds a system that can play any local or web videos, gives volume control, play, pause, playrate, etc and doesnt require a huge setup. Just feed in the file path and away it goes.

Were actually happy to switch to this because it gives a lot more control over the built in Video Render Framework. :slight_smile: Uses VLC libraries.

1 Like

Hi all, I ran into the same issue and found a solution!

Yes, the media player is broken, BUT!!
If you enable the plugin “Apple ProRes Media” then it will be able to play ProRes videos afterwards!

So all you gotta do is enable that plugin and to transcode your videos to ProRes.

9 Likes

Here are my settings for transcoding:

4 Likes

That’s great, but i really don’t want to pay 45£ to fix a problem that shouldn’t be there in the first place

5 Likes

Oh my goodness, THIS IS THE SOLUTION. Enabling the plugin fixed the media player. All supported formats are working now

2 Likes

Does it work after shipping build packaging? Because while we were able to get certain things to work ain debug/development build, shipping made them stop working again.

If is does, that’s awesome!

Hi all. Try to switch Default RHI to Default in Project Setting → Windows.
image

17 Likes

I have done this but since switching to ‘Default’ and although this did solve my problem it has made the engine really laggy and very unusable so gonna try it on DX11 see if that makes a difference.

Edit: Just tried it on DX11 and it was also very laggy. This is so unfortunate as well

[OFFICIAL] Wondershare UniConverter: Your Complete Video Converter and Toolbox

This is a free convertor for you that converts in to ProRes Codec :slight_smile:

Edit: Will only convert to ProRes if you are using a Mac >_<

I also was able to solve this by switching to DX11, but something else that is happening now with the media player is I can only get it to play the audio of the video or any audio on one media sound. Any other media sound that is playing the audio from the video is muted. This didn’t happen before.

Basically New DX12 not working with Media, I think it is a bug.
And DX11 not support Nanite…

So your Video don’t have audio, you can use Image Sequence to play it.
https://docs.unrealengine.com/4.27/en-US/WorkingWithMedia/IntegratingMedia/MediaFramework/HowTo/ImgMediaSource/

If your video has audio, you have to split the audio two another file.
Create a BP to play the audio and ImgSeq at the same time.

This is not a good way to do it. But I worked for now.

1 Like

I tried switching to Vulkan, and for what I can tell my videos and nanite seem to be working as expected. Your results may vary.

looks cool! can you control playrates in a stable manner and within a wide range (-1000 to 1000 eg)?

That worked for me :slight_smile:

1 Like

I do believe so. There is playrate.

1 Like