UE4 Lightning does not build


I’m having a problem with the lightning build. Everytime I try to do the building the Swarm stops doing it, I’ve tried everything I have found in other questions posted, some said it was a bug that’s already fixed, other that change this or that, I have tried all of them but one.

How do I rebuild the UnrealLightmass.cpp? None of the forums have the answer, I don’t have GitHub, I’m using Visual but it doesn’t appear in the folder it was supposed to be. I don’t even find the path

Please I really need help on this because I really don’t know what to do and I’m running out of time. Everything was working, always did the building until today without reason.

To rebuild UnrealLightmass, right click on it and select rebuild.

Hi Clean,

First off, thanks for the reply. The thing is that I don’t see that in my project, this is what I have

You have to build the LightMass when you’re building the engine source.

Yes, is right. In other words, you have your personal project open in Visual Studio. Close that and open the actual Unreal Engine (UE4.sln) in Visual Studio. That file should be in a directory that just holds the engine source code.

Thanks guys, I’ll look into it, I’ll post again if I have more questions about that.