Shadows very glitchy in only the right eye in VR

If I create a clean VR Template and run it, the shadows on objects in the right eye flicker, depending on head/object positioning

In this image, see how the right controller has no shadows on it:

And I’ve captured a short video here - note that the shadows pop on and off on both the cube an the controllers, and that sometimes the shadows end up projected all over the rest of the scene instead.

I’ve run across some sporadic threads from the past, for example 1, 2, 3

But the few things I’ve seen proposed as solutions do not work. Turning off instanced stereo breaks the right eye completely:

I also tried switching Shadow Map Method from Virtual Shadow Maps (beta) to Shadow Maps and that changed what the broken shadows looked like, but they were still super broken in the same way (right eye glitchy, projected all over the rest of the image).

I’m on a GTX 980 Ti, HTC Vive, latest drivers on everything.
I haven’t adjusted anything from the clean template, so all the VR-specific settings should be good - i.e. forward shading is on, etc.

1 Like

I just downloaded UE4.27 and created a VR Template project in there, and I don’t see the same shadow problem there. Looks like it’s just in UE5.0.

In UE5-EA2, I’ve run into the same issue.
Through my testing, I’ve found this only happens with stationary lights that have the property: “Dynamic Shadow Distance StationaryLight” set to 0.
Setting this to a value other than 0 seems to have fixed it.


You save my week Thx!

1 Like

You saved me a LOT of time too! Thank you!

1 Like

I just wanted to hop in to say, this is still a problem with 5.2 and the above solution still works!