Shadows only show up for first LOD

I’ve got some grass placed with the foliage tool, but the shadows are only appearing on it for the first LOD.

Here’s a screenshot:

The materials are almost identical between all LODs with the only exceptions being the textures and normal maps.
“Cast shadow” is enabled for all LODs.

I got so frustrated trying to figure it out that I started over and made a new set of grass from scratch, but I still had the same problem.

Anyone know what’s causing this?

Hi Evan,

I wasn’t able to get the same results so I have some questions for you.

  • What settings are you using for your Directional Light source?
  • What settings have you enabled/disabled/changed for lighting within the Foliage tool?
  • If you remove the LOD or adjust the LOD distance does the problem go away?

If it’s not reproducible with any other assets, like the foliage pack someone made here for free, can you provide a test project/asset that can reproduce this. It may be easier to just look and see what’s going on and give some feedback if the information above doesn’t help.