Shadow on topology of custom vertex normal mesh

There’s a slight AO shadow between the bevels in my custom vertex normals mesh. This happens in UE4 but in blender it looks fine. I imported the fbx with normals and tangents, it’s set to movable with no baked lighting, I tested all the cast shadow options in the lightmass settings but nothing seams to work.

This also happens on low poly surfaces, this surface should appear smooth like a subdivided model due to tangent normals, but the shadow kills that look.

To me it looks like a side effect of screen-space ambient occlusion.
Usually it is unnoticeable, but at certain conditions( namely concave shapes with relatively low polycount) it can occur.

Turns out the post processing volume is responsible, I can turn down the AO intensity to solve the issue but then it looks bad from having no AO. I’m not able to tweak it in a way where it doesn’t darken such wide angles, which would be the ideal solution. I guess I just have to add more detail to the mesh itself.

The solution was in the post processing volume as suspected. The radius option under AO settings has to be tweaked along with power, intensity, quality, mip scale to completely remove shadowing on wide angle geometry. Those were the options that worked for me, it might vary from case to case.