Shader's not compiling

So, I asked on reddit, the forums and earlier today I couldn’t log in here. NO RESPONSES.

Shaders hang when they start and never compile.

Uninstalled engine versions 4.22 4.23 4.24 completely. Uninstalled the launcher. Had previously moved the DDC to it’s own folder where it worked and still no shader compiling. Added redundant allowances for the editor and shader compiler in the firewall to make sure windows 10 didn’t do something stupid again. However I doubt that is the case because it started building lighting after reinstall of course it froze at 33%.

STILL after fresh install (which wasn’t exactly a clean install because now when you uninstall it leaves all your settings behind),

Honestly I am at wits end.
I guess after all these five years I am forced back into the market for a new engine. UE4 has become horribly bloated and slow anyway. I just wish you would refund me the thousands of dollars in assets I bought in the marketplace throughout the years.

I thought epic were the good guys.

Hi. We test 4.24 with our project and all went ok (except a strange display in the shader notification window).
I guess 4.24 is still bugged as it is fresh new. Do you have same problem on 4.23 ? (we are using this version at the moment).

I have the exact same problem, I’m currently using 4.24 and the shaders don’t compile and it freezes for building lighting and tried the same thing, i had this problem in 4.22 that’s when i downloaded 4.24 thinking this might solve the issue but it still persists.

I have this issue on 4.22 4.23 and 4.24. I installed the conan exiles dev kit which I believe is 4.15 and shaders complied fine. My only recourse at this point is completely uninstalling the engine and hunting down and removing every single hidden file and taking them out and reinstalling. No one got no time for all that.

So, an update. I decided to completely remove all epic everything and reinstall. Dug through all the directories in the app data directory removed them. uninstalled all engine versions and every directory pertaining to them. Cleaned out my registry.

Then reinstalled the launcher and guess what? When I try to log in “It seems that you are trying to send request twice.”

Uh what?

This is SOOOOOOOOO IRRRRRAAAAATAAAATING! Years of development, and tons of cash spent on half ■■■■■ assets wasted… Because epic is to busy doing whatever else they are doing to make sure their engine is in a good state.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


I suppose after speaking with several support crews at epic, the answerhub, bug reports, the subreddit, and several different re-installs of various versions, it appears that this issue is completely f@%!ing unsolvable for me. As of this last post, I have lost so much dev time since 4.24 released that I am done.

EPIC you have put me out of business, so enjoy all the money you have been getting from me since 4’s marketplace. All that anyone had to do was figure out why the engine launches the CrashReportClientEditor program (in the background and not logging) before even launching the engine. As this happens all the time with every version, and the source for 4.24 is unbulidable do to permissions, this is totally unacceptable.


Dug through all the directories in the app data directory [mcdvoice][1] removed them. uninstalled all engine versions and every directory pertaining to them. Cleaned out my registry.

well, i had this problem two month ago and to be honest I’m not entirely sure how i fixed it but i thought maybe i could help a bit. after i completely uninstalled the engine and installed again and the problem was still there i figured perhaps there is a program that is preventing the engine from compiling the shaders. so i uninstalled a lot of stuff on my computer including visual studio and all it’s components and some other programs that i don’t really remember and then i restarted my PC and opened unreal and the problem was solved. i don’t know if your issue is similar to mine but i suggest you look into this, i hope this helps.