Project crashes on startup but only on one pc

I am working in a small company, we are a team of 3 people. We share the project via Plastic scm, and after one of the updates the project started crashing on launch, but only on my computer. Please don’t chuck this up to plastic problem allow me to explain. The problem occurs only on my pc, even though all files are the same. The only thing different between the computers is that I use windows 11, up to date, and they use 10. All the rest of our specs are the same. The issue is only with the main level, when launching the main level the crash occurs. I know this because when launching the project after deleting the config folder I am greeted with the empty untitled level, only to crash when opening Main. I mentioned a plastic update, but the weirdest thing is that when I reverted my version to before that hellish update, it still crashed, as if something is internally screwed. Also, worth mentioning, this only happens on this specific project. Another heavier project on the same version is fine. I would like to reiterate that it’s only a problem for me, not my team. Here’s a detailed list of attempted solutions, needless to say, none worked.

  • Restarting my pc
  • Resyncing all files to source control
  • Coping files from one of the other computers by hand and launching it without connecting plastic source control
  • Verifying unreal files through launcher
  • Deleting all generated folders (saved, config, intermediate, DerivedDataCache) before launch
  • Replacing the DX from 12 to 11 in the defaultengine.ini as suggested online (can’t access project settings because it wont launch)
  • Deleting all unreal engine local AppData
  • Updating graphic driver
  • Suspending antivirus

Here’s the crash info:


Assertion failed: ReaderPos + Num <= ReaderSize [File:D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Serialization\BufferReader.h] [Line: 52]

UnrealEditor_MeshDescription!FBufferReaderBase::Serialize() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Serialization\BufferReader.h:52]
UnrealEditor_MeshDescription!operator<<() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Containers\SparseArray.h:630]
UnrealEditor_MeshDescription!operator<<() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Containers\Set.h:1074]
UnrealEditor_MeshDescription!FMeshDescription::Serialize() [D:\build++UE5\Sync\Engine\Source\Runtime\MeshDescription\Private\MeshDescription.cpp:195]
UnrealEditor_MeshDescription!FMeshDescriptionBulkData::LoadMeshDescription() [D:\build++UE5\Sync\Engine\Source\Runtime\MeshDescription\Private\MeshDescription.cpp:2126]
UnrealEditor_Engine!FStaticMeshSourceModel::LoadMeshDescription() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\StaticMeshSourceData.cpp:169]
UnrealEditor_Engine!FStaticMeshSourceModel::CloneMeshDescription() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\StaticMeshSourceData.cpp:192]
UnrealEditor_MeshBuilder!FStaticMeshBuilder::Build() [D:\build++UE5\Sync\Engine\Source\Developer\MeshBuilder\Private\StaticMeshBuilder.cpp:420]
UnrealEditor_MeshBuilder!FMeshBuilderModule::BuildMesh() [D:\build++UE5\Sync\Engine\Source\Developer\MeshBuilder\Private\MeshBuilderModule.cpp:50]
UnrealEditor_Engine!FStaticMeshRenderData::Cache() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\StaticMesh.cpp:2844]
UnrealEditor_Engine!UStaticMesh::CacheDerivedData() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\StaticMesh.cpp:4919]
UnrealEditor_Engine!UStaticMesh::ExecutePostLoadInternal() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\StaticMesh.cpp:5561]
UnrealEditor_Engine!FAsyncTask::DoWork() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Async\AsyncWork.h:303]
UnrealEditor_Engine!FAsyncTask::DoThreadedWork() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Async\AsyncWork.h:328]
UnrealEditor_Core!FQueuedThreadPoolWrapper::FScheduledWork::DoThreadedWork() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Misc\QueuedThreadPoolWrapper.cpp:21]
UnrealEditor_Core!FQueuedThreadPoolWrapper::FScheduledWork::DoThreadedWork() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Misc\QueuedThreadPoolWrapper.cpp:21]
UnrealEditor_Core!FQueuedThreadPoolWrapper::FScheduledWork::DoThreadedWork() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Misc\QueuedThreadPoolWrapper.cpp:21]
UnrealEditor_Core!<lambda_925f6c2453012060ddab4eb171196a20>::operator()() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Async\Fundamental\Task.h:333]
UnrealEditor_Core!LowLevelTasks::TTaskDelegate<void __cdecl(bool),48>::TTaskDelegateImpl<<lambda_925f6c2453012060ddab4eb171196a20>,0>::CallAndMove() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Async\Fundamental\TaskDelegate.h:171]
UnrealEditor_Core!LowLevelTasks::FTask::ExecuteTask() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Async\Fundamental\Task.h:426]
UnrealEditor_Core!LowLevelTasks::FScheduler::TryExecuteTaskFrom<&LowLevelTasks::TLocalQueueRegistry<1024>::TLocalQueue::DequeueGlobal,0>() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Async\Fundamental\Scheduler.cpp:280]
UnrealEditor_Core!LowLevelTasks::FScheduler::WorkerMain() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Async\Fundamental\Scheduler.cpp:320]
UnrealEditor_Core!UE::Core::Private::Function::TFunctionRefCaller<<lambda_776551d1e343b6cb7eaf0e5521c77c81>,void __cdecl(void)>::Call() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Templates\Function.h:549]
UnrealEditor_Core!FThreadImpl::Run() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\HAL\Thread.cpp:69]
UnrealEditor_Core!FRunnableThreadWin::Run() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:146]

Here are some logs:
RavKuk.log (78.5 KB)
RavKuk-backup-2022.10.20-12.02.28.log (94.4 KB)
RavKuk-backup-2022.10.20-12.05.37.log (101.0 KB)
RavKuk-backup-2022.10.20-12.06.31.log (120.5 KB)
RavKuk-backup-2022.10.20-12.08.54.log (113.6 KB)

I am begging you if you can help at all even give me a direction of what to look into, I don’t know what to do anymore I’ve already spent two full work days trying to solve this

RavKuk.log mentions
LogWindows: Failed to load ‘aqProf.dll’ (GetLastError=126)
LogWindows: File ‘aqProf.dll’ does not exist

This thread mentions with the apProf.dll error that they had some uncompiled blueprints in their project causing the problem.

just below you have the lines
LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.
LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.

Seems you have an unsupported resolution on this specific PC. Does it have a normal GPU or is it an integrated graphics chip on this specific PC / laptop?

Thank you for the answer!

I first recompiled all my blueprints, didn’t seem to work. I also double checked my GPU, it’s a normal Nvidia RTX A4000, and it is indeed the same as my peers

Do your colleagues PC have the same updates, windows build and graphics driver versions?

Regarding the windows version, as stated I am the only one of us to have windows 11, I could see that causing problems since windows versions are always so much fun, but it begs the question of how do I solve said problems.

Now regarding the GPU we’ve now compared them extensively and a few things came up. First of all, my driver is ever so slightly later version, they have while I have
Secondly and probably more importantly, we all have 2 GPUs one the RTX A4000 and the other is actually integrated graphic chip of Intel(R) UHD Graphics that I have not noticed before (my apologies). I have 770 and they (both) have 630. Moreover, when viewed in System information → Display, they have their Nvidia as the first one displayed and intel second, but I have the intel first and Nvidia second, which I’m assuming is a matter of priority for the machine? To try and circumvent this I went to graphic settings and set unreal to use strictly the “High performance” setting AKA the Nvidia instead of the default “Let windows decide”. Unfortunately it did not work.

I just had a similar issue, I solved it be reverting my CPU overclocking setup. If you’re not overclocking try underclocking and see if that works