Download

Pop up menus stop working after a while

This is getting annoying…

I havnt managed to work out whats triggering this yet but its happening alot, usually within 10-20 minutes of starting the editor.

I think but I’m not 100% sure this started after I got a new monitor, used to have a really old dell 24 inch 1920x1200 59mhz monitor. Now I’ve upgraded to a asus rog swift pg279q running 1440p 144mhz gysnc. I havnt really used UE4 for a few months before I got this monitor so could just be coincidence.

Basically after a short amount of time right clicking on anything that brings up a pop up menu doesnt work anymore, the pop up menu either flickers or pops up then disapears instantly. Also once this starts occuring opening up a blueprint just produces a black screen, alt tabbing out the editor and back in normally then shows the blueprint correctly.

Restarting the editor fixes the problem but then it’ll start happening again 10 minutes later.

Also the editor seems to break my monitor sometimes, i get a line that starts at the top in the middle and runs halfway down the screen. Looks a bit like the top right hand side of the screen has moved a few pixels over the left and now is not lined up with the rest of the screen. Now I think about it…looks kinda like tearing when you’re not running any syncing like vsync or gysync, but permanent. Restarting the monitor doesnt fix that issue but changing the mhz to 165 then back to 144 fixes it. No other software\game does this to the monitor.

Now I think about it…I’ll try running the editor with gsync switched off see if that makes any difference…

(EDIT: probably not gsync its set to only run in fullscreen mode)

Engine version 4.26
Specs:
rtx2080 super
I7-8700k
16gb ram

Hi! This happens with Quixel Bridge/Mixer as well.My workaround is to right-click on Unreal’s task bar icon and toggle Maximize/Restore. No need to exit the Editor here.

By the way, Mixer’s “Export” button on the bottom right corner seems to disappear sometimes. The same workaround applies.

Ah now that is intetesting I’d forgot I’d recently installed the Quixel bridge thing. I’ll try removing it and see if that makes any difference.

I just wanted to say that I’ve been having this EXACT issue probably since March, and still have it. It’s annoying AF and I have no idea what’s causing it, or how to fix it. Whenever it starts happening, I have to save everything and close/open UE again.

The most annoying part is opening all tabs again, and remembering what I was doing.

there are multiple reports of this bug for almost a year now, and no actual fixes that work apparently.

https://answers.unrealengine.com/questions/967747/submenus-disappearing-bug.html
https://answers.unrealengine.com/questions/1010618/how-do-i-fix-disappearing-menus-and-black-screens.html?sort=oldest
https://answers.unrealengine.com/questions/1007438/view.html
https://answers.unrealengine.com/questions/1005720/black-dropdown-menu-in-unreal-menus.html

the workarounds include installing a (VERY) old geforce studio driver or switching to vulkan. none of which are a proper fix.

Any fixes yet? I’m on UE 4.27.1, 32gb ram, rtx 3080, r9 5900x

What exact OS version and gpu driver are you running (winver command in Command Prompt)? This is a tricky issue to find reliable repros for. If it pops up again, can you capture a dxdiag log (type dxdiag in windows start menu) and upload to help troubleshoot?

In the meantime the most reliable known workaround is following the instructions in this Nvidia Support Knowledge Base Post to disable the Nvidia MPO feature.

I noticed this issue only appeared on my 4k screen. If I drag my window to a 1080p screen, the black menu issue goes away.
It’s an interesting clue to take into account