Oculus Quest performance issue just in one Level.

I’ve developed a VR experience for Quest with 12 scenes with buyed props of the marketplace for a ver strange job…
Well, all was working arround 2 months ago in 4.24, but I had to migrate it to a 4.25 blank project for plugins and Android issues.

Now 11 of my 12 maps/levels/scenes are working fine, but 1 is horrible. I have to submit my work on 3 days and I don’t know what else can I do.

The issue is with the performance of the map, is like “lagged” as you can se in the video below:

I have the Quest settings (Forward rendering, FFR res in Ultrahight, 4xmsaa, CPU and GPU in 3, no HDR, and all that stuff) as Epic Games and developers say and all the rest is working fine, but this map not, it even has lighting issues, but in 4.24 was perfect (aceptable).

That’s what I tried with the lighting:
-Force no precomputed with sun and sky lights (stationary) and a sky sphere
-Precomputed lighting with the same lights
-Build lighting with the same lights but in static
-Light with just 1 point light
-Delete the sky sphere

Nothing worked.
The mesh is great (In 4.24 worked).
Textures are the same (I’ve resized to be samller now for trying something)

It’s smaller in pollygons and textures than other maps so IDK what’s going on. Any help?

Thank you so much!

Have you tried profiling the application? You should be able to detect there what the actual issue is.

(Also check if you’re doing CPU heavy activities, these could also cause problems on Oculus Quest. )

You could check out the profiling tools from oculus for quest here:


or try and use the unreal profiling tools by enabling some stat commands. (although they may be hard to read in quest)

You can enable these in game on Quest by Executing a Console Command on begin play.


Hi, can you show images of the result of “stat unit”, “stat game” and “stat gpu”, where it is lagging?

Allright, as both of you asked me I’ve done some analysis job with the OVR Metrics Tool but I don’t know how to record it, is like transparent in the recording.

But I got the issue: 99% GPU usage and 5 GPU level just opening that map.

The CPU level remains arround 2-3 and the usage below 40% so it’s a GPU issue. Btw, 72 Stale frames. FPS fall from 72 to 20-30

I don’t know how to do GPU profiling to see more detailed info.

Any idea?

Thanks a lot!

Edit: I'm repackaging it with the "State unit draw command" to see how it works.

The Stat Unit Draw was an example on how to display a certain profiling.

If you want to profile GPU you could do Stat GPU

So if I understood well that’s what I (and you) need to see whats going wrog (plus the data provided before).

What that means? I’m lost in the analysis because it’s my first time. I did it sometime but only with fps and easy values.

Thanks a lot!

Yep, posted now below. I didn’t know how to do it.

You’d want to do the profiling on the Oculus Quest, as the hardware is way more limited there than on your PC. The problem may be easier to spot.

By the option “Lauch on device” i guess. Let’s try that.

Ok, nor lunching or packaging I can do it. How can I see that same stats when running on Quest?

Try adding a delay node between the BeginPlay and the Execute Console command. (Delaying it a few seconds can help it to pop up)

I did a lot of checks. I did that and I can see when looking some directions GPU goes crazy to 99%.
I deleted every material and half of the meshes (in a new map).
I thing the only problem are the assets, the satic meshes itselves but in 4.24 was working well. I thing I’m modeling the map by myself to ensure the deadline of the project even if it is 40 hours of extra job for me, plus 20 hours that i spend profiling. Idk what goes wrong.

Thanks a lot for teaching me that.

Sounds like you have too many triangles or drawcalls then. You can check the triangle count using Stat Engine, oculus suggested to not go over 100k tris rendered in per frame on Quest 1. ( https://developer.oculus.com/documentation/unreal/unreal-debug-android/ )

You could try and create lower LOD’s automatically for your assets, especially the ones in the distance, and decrease their max LOD level to automatically try and lower your triangle count.

But the most interesting part here is that the map worked fine in 4.24, but started to have performance issues after the OP upgraded to 4.25?!

I mean, the info about “howto enable debugging tools” is a good help, but the main problem remains: It worked in 4.24, and fell apart in 4.25.

@Samush94, did you ever figure out what your problem was? Because I’m observing something similar after going from 4.24 to 4.26.

Hi! Nope, i don’t know what happened. In 4,24 worked fine but I couldn’t do it in 4,24 anymore (for external reasons).

I’ve never found a solution, I just forced it in terms os scalability, resolution and GPU level… it was not a huge project, just for a local customer so no problem for me but is an issue…

Btw, thanks for this answer, I’ve never fixed it because I couldn’t but I improved it with your tips in order to make it aceptable again. Thanks.