Navmesh randomly decided to stop working

I am trying to set up a basic patrol AI. I had it working yesterday perfectly fine. Today it didn’t work and on investigating I learned that my navmesh was not generating.

I have it set to show in the tab and have spammed the P key. I have not changed any of the settings since it last worked. The floor is unchanged. I have tried deleting the navmesh and the ReCastNavmesh-Default that appears and making a new one. I have tried moving it around and resizing it. I have tried loading a new level in this project and adding a navmesh there, that does not work. I have tried making a new project and adding a navmesh and that DOES work. In my main project the only thing I have changed in navmesh settings is making it dynamic, I have set it back to static and it still wont work. I’m also not using navigation invokers, just the basic navmesh.

I could migrate things over to a new project as a last resort but what if this happens again, Its really annoying.

Any ideas how to fix this?