Nanite issues with raytracing enabled


goodmorning everyone . i post this com because of an issue i noticed : when i enable nanite in my megascan assets with raytracing enabled , some black artifacts or mini black shapes appear on my assets , when hitted by the sun . these black artifacts are not visible when my assets are not enlighted by light .

any help please or solution if some of you have the same problem than me ?

Raytraced shadows have to use the Nanite proxy mesh and will give poor quality shadows. There’s no good work around and probably no fix on the horizon. VSM were designed to work well with Nanite and is the best shadow option for Nanite heavy scenes.