Mixture of Nanite and Non-Nanite meshes breaks lighting

I upgraded a project I had from UE 4.26 to UE 5 and then converted my meshes to Nanite, but there were certain models that didn’t work with Nanite so I didn’t convert them. But I instantly noticed something wasn’t right with the lightning in the scene anymore. After some testing and troubleshooting I found that the issue is that if you have both Nanite enabled meshes and non-Nanite enabled meshes it causes the light to not render on objects properly.

I created an empty scene with 3 objects as an example. In the first image all 3 objects have Nanite enabled and the lighting works as intended. However, once you disable Nanite on a mesh, the light no longer renders properly on the meshes that have Nanite enabled. Is it not possible to have both in a scene? Do you have to have everything Nanite or nothing at all?


After some more troubleshooting I figured out what was causing the issue. On my master material (which is used on most of my static meshes), I had a parameter for a Anisotropy plugged into the Anisotropy node for the material. After I disconnected this node, the lighting started rendering correctly even when using mixed nanite and non-nanite meshes.

Long story short, it seems Anisotropy isn’t properly setup to work with nanite at the moment. Or at least if you are using mixed assets with some using nanite and others not.