Metahuman hair reflecting strangely with lumen

Hi all,
I am having issues with the hair on some of my metahumans. When hitting a certain angle of light it gives off an exremely bright and shiny hair effect which shouldnt be there. I beleive it has something to with how lumen is impacting the lighting of the strands.
LODs are set to 0.
IMage with Sky light turned off -
Image with skylight (and i assume lumen lighting) on -

Ive tried almost everything in the hair settings within the metahuman.
Any advice would be greatly appreciated.


Do you have any emissive material in your scene? (Like the phone’s screen)

I had a similar problem and I “fixed” it removing the emissive material, apparently Lumen doesn’t handle it very well yet:


Thanks for the reply, unfortunately the only emmisive material seems to be the skylight. I cant find any other emmive materials. Ive had this issue in multiple projects now and just cant seem to find a fix for the shiny glowing hair

1 Like

There is a setting, i think under experimental in proj settings, deep…something setting I saw earlier that mentioned it helped with hair… finish compiling shaders and ill look for it

1 Like

Cast deep shadow, in the directional light (i assume other lights as well)

After looking it up Im not sure that would help but worth a try…

Hi, did you ever manage to find the solution to this? I am currently dealing with the same issue

Why is there no solution to this yet?

Hey gang, I found the issue!

Metahuman hair / groom has an odd bug where if you have any emissive objects in the scene, the hair seems to bug out and reflect through the hair. You need to turn off
all emissive materials that are adjacent to the hair or else it will shine through oddly. Hope this helps.

Has anyone found a fix yet?


Has still nobody found a fix since last year??? I’m having the same issue right now

Found a temporary fix, bring the hair roughness down really low, like .02 or something. 0 works too, but then hair looks wet

EDIT: This solution sucks, it makes the hair all sparkly, Only other fix is to just make the hair black. Why has literally nobody figured this out?

Hello everyone, I’m embarrassed to say how long I’ve struggled with this issue and used various bad workarounds. Decided to give it a go again and see if I could find a solution. I’m happy to say one thing that works quite well for me is a setting in the Groom itself. Look for “Scatter Scene Lighting” on the Strands tab and turn this on. This worked quite well for me. The groom looked much better with Skylight/Lumen GI/etc. In my case these bad reflections would show up only in certain camera angles and lighting setups (almost always when I was shooting a dark interior with a bright skylight and directional light illuminating an environment outside a window). This “Scatter Scene Setting” could require some changes to your Groom material and may not be desirable in certain lighting setups. I think it should probably be a tool in your toolkit to resolve this kind of thing rather than a one-stop-shop that fixes all Groom reflection issues. Very possible it may cause problems elsewhere so keep an eye on it!


For me the issue disappears when setting the LOD to 2 or lower. That is obviously not ideal, but it actually looks better.

ah ha! this worked for me, thank you so much for posting it!

Group asset > Strands Tab > Scatter Scene Lighting: checked on.

There’s also that same option selecting the Hair component, under Groom Groups Desc that seems to solve it too without the strands tab one set.


Worked for me as well! THANK YOU

1 Like

Worked thanks

1 Like

Hi there! Just got the same issue with shiny hair. I just discovered that this shininess is resulted by skylight, or some specific HDRI’s. So, another solution may be - is to turn of skylight (but again, I understand that it’s not a great solution at all, because you need skylight for general indirect lighting), OR, try several different HDRI’s without really bright parts on them. It may work.