Major fps drop with only a few foliage instances

I found these 4 leaf clovers that are PERFECT for my game, i have them all set up but when i use the foliage tool to start placing them, i get a massive fps drop with maybe only 10 VERY SMALL clovers. please shoot me a list of possible things i can try. all other foliage works great, except these clovers for some reason!!

I had some major FPS drops yesterday it was down to my material and I fixed it by just reimporting the textures,

hmmmm. much appreciated for your answer. i thought that would work for sure, guess not. i even tried to take out the textures and leave it blank while it is placed in world. still a huge fps drop. i have done everything from turning textures,silhouette,shadows down/off. reduced everything i could. any other ideas??

  • Are they casting shadows? Try disabling
  • Big number of polygons per item?
  • Translucency? Try changing the material mode to Masked
  • Press ~ and type stat SceneRendering. Is the amount of Draw Calls high (above 300-400)?
  • Press Ctrl + Shift + , (comma) in game - once when you have this clovers on the scene, and once without them. Does some cost (like Translucency) rise significantly?

Regards,

Oskar

hey oscar, thank you for the response.
Shadows are disabled
how do i check the polygons per item?
translucency is set up normally and working fine, it is Masked.
my mesh draw is 790, not sure if that is a good thing or bad.
i didnt see any change with the translucency when changing.

Okay. 790 draw calls sound like a lot, but not extreme (we had 350-450 in a PS4 game, though a lot of things were static).

Amount of polygons can be found in static mesh’s edit window. But check the full triangle count in your scene first, by console command ‘stat rhi’. I recorded some videos on measuring performance - UE4 Graphics Profiling - YouTube

dude, much appreciated! ill try this out!

Did you resolve it?

unfortunately not yet, i am still trying to figure out why some foliage drastically lowers fps while the rest are fine when you look away from them, so weird.

oh! i think i figured it out, a couple things,

  1. the LOD was set to level architecture for some odd reason, maybe import error, so i set that to foliage, then the light resolution settings had a little yellow reverse button, so it went from 64, to 4, i hit save and seemed to work alot better.
  2. what seemed to be my main reason of fps loss was a cluster of rocks in the sky (not sure how, why,of what the hell) but i deleted them and instantly went back to regular FPS. so i guess it was all just MY error.

Thank you all for your support on this topic!! it is honestly really hard to get people to respond to you’re answerhub posts, so thank you!