Download

Lumen GI and Reflections feedback thread

What videos?

At around 18:00… the mirror reflections here look a lot nicer - I have changed the settings to reflect the same result (final gather 4, reflection quality 4)

Looks about right to me. As he says in the video indirect light still uses the surface cache, and your scene is pretty much entirely indirect light.

Being a noob, can you please elaborate on your answer? So, adding more elements will make the scene look better?

Adding direct lighting will make the reflections look better in areas that are directly lit. I posted about this previously in this thread: Lumen GI and Reflections feedback thread - #67 by Arkiras

To my knowledge there is no way to improve the reflection quality in indirect light, even in your video the reflections are still low quality in the indirectly lit areas.

1 Like

Have a “stupid workaround” for the “overshadowing of trees” issue…

  • Put a light into them… yes, i know, its dumb… but gotta use what you can.

Of course, this only works for games where trees are not too common and manually placed too.

Result:

Definitely better than the alternative options.

That said, I am still fighting with Lumen (and UE5 in general, but I am making progress in “working around the issues”.)

I would love to have lumens settings exposed to the post process volume, stuff like: “ray length, voxel size” etc. in the future.

EDIT:
I also noticed that the Issue described in #48 only appears on maps with many actors, have not seen it appear on maps with <3000 Actors/Meshes etc. so far.

Maybe too many things can overload Lumen? (Which would be counter-intuitive, given that we are supposed to build the game from pieces for lumen to work properly…)

For some reason, screen traces for lumen reflections appear to have just stopped working at some point and now always render black in my test project. Has anyone encountered this?

Feels like I must have messed up a setting somewhere.

Disabling Lumen in Post Process Volume leaves behind “shades” on static meshes.

If Lumen is supposed to be enabled/disabled at runtime in a games settings menu, this needs to be sorted out.

Lumen screen tracing produces artifacts in a simple scene.

As shown below, the ground has a low roughness value (~0.2). When the screen tracing is enabled and the camera is facing the ground, Lumen gives white color under the horizontal bar of the “T” shape, as highlighted by the red rectangle. When the screen tracing is disabled (r.Lumen.Reflections.ScreenTraces 0), the artifacts disappear. In addition, when the camera is not facing the shinny ground, the artifacts are greatly reduced.

For more details, see this post: Lumen GI and reflection produces weird visual artifacts

I searched this thread and the bugs and issues page, but couldn’t find any occurences. Sorry if I missed something.

Do the devs already know about the issue mentioned in the following thread? →
[Lumen] Some odd light culling(?) behavior

I need to extend all my local lights attenuation radius’ and I can’t use global light sources for interior.
As soon as I’m facing away from the global light source, all light bounces from the respective window are getting culled. The workaround for local light, as mentioned in the thread, is to increase the attenuation radius until the culling doesn’t matter, which isn’t optimal in terms of overlapping lights performance.

Disabling screen tracing doesn’t fix the issue.

Are you on EA2?

I just tried to replicate this issue, but could not do so.

Threw a spotlight in front of a wall, with disabled sunlight and colored it blue

then I turned around the camera and went away 3600 units from the light, with the light being definitely “out of view” including its attenuation cone.

But I still got its GI:

EDIT: Did another test, very close to the wall like you did, still works:

So the issue might not be the light itself, but something in your scene in combination with the light. (your mirror? etc.)

Switching on/off “Game settings” also doesnt break the light for me, I still get GI from it, allthough its less visible due to different settings now.

He didn’t make that thread, I did. It’s still broken in EA2.

The mirror doesn’t matter, it happens with or without it. I only put it there so that I can visualize the Lumen scene and the main scene at the same time.

Is this a Scene you imported from EA1?

If so, creating it from scratch may solve the issue, I had lots of broken things in an imported scene too. (EA1 really was broken from my experience)

Do you have the scene for download, maybe I can figure out precisely whats going on, since I spent significant time “getting lumen to behave” with the issues it currently has.

I can definitely not replicate it, not even in a new project if using EA2.

Probably a specific setting that causes this issue, you might want to check them. (If Epic is supposed to fix this, they need the detailed information, since the light itself seems to work.)

Here’s the entire process of reproducing this in EA2, start to finish including project creation

Literally all I can tell you is it depends on where the light is positioned, if you move it closer/further from a surface in any direction it will sometimes fix itself but there are clearly dead spots where the light is instantly culled the moment the spotlight frustum is off screen.

Could replicate, could partially fix.

You need to give your Spot Light an “inner cone”, otherwise what you describe will happen.

I automatically did it, which was why I couldnt replicate it.

So the issue is:

Spot Lights with an “Inner Cone” that is “narrow” (< 15 for example) can get culled from Lumens GI if the Outer Cone is not in View frustum anymore, while the light is close to a surface…

This also depends on the walls in the scene.

Doesn’t solve anything for me…

It also seems to depend on the scene.

If you put a wall “behind” the light, it works, if you remove that wall again, it breaks again, regardless of the inner cone angle.

Issue 1 (still working on the images for the 2nd.)

Setup:

As long as the back wall is there, the GI works:

If you remove it, it completely culls the light:

Issue 2:

Setup (see inner cone):

As soon as you move closer to the wall, the light gets culled:

But this does only happen with narrow Inner cones.
Putting the “Inner cone” at 20, it works again:

I am not sure if this is 1 or 2 bugs, but there certainly is something broken.

Luckily, for most cases the workaround of “having an inner cone” should work, for now. (coincidentally, thats why I couldnt replicate it, giving spot lights an inner cone is pretty much the first thing I do after bringing them into the world, for visual purposes.)

Feel free to add this to your bug report, so that epic has a “starting point”.

EDIT: My thoughts:

  • Could it be that the “outer cone” only does screen space GI, while the Inner cone does proper traces? (that would explain Issue #2)

  • the wider the cone, the more GI I get in the above setup “behind” the light.

  • Lumen “breaks” when “looking into the void” (the removal of the wall is exactly that, and it doesnt appear to happen if there is another room behind the wall.)

1 Like

Another Issue I found.

Note: Auto Exposure is not enabled and/or locked in place. (Auto Exposure is not the issue here, even though it behaves similarly.)

A corner of Walls from “further away”:

If you get closer, it seems like the SSGI part of Lumen creates way too much GI, shifting everything to white:

Does not happen in all corners, still trying to figure out what the exact conditions are.

EDIT: It would be nice to have an option to set a “limit” on how bright the GI can get, in the case that this is not fixable.

Hello,

does anyone have the r. commands for Lumen, since they are not listed on both the documentation sites and Google isnt helpful either.

specifically, the command that determines the trace distance for the high quality traces.

Thanks

Just type lumen into the command prompt in the editor and you’ll get a huge list of them

UE5_Cmdprompt

The one you’re looking for specifically is probably r.Lumen.DiffuseIndirect.MaxMeshSDFTraceDistance

1 Like