Download

[Lumen] Some odd light culling(?) behavior

[Lumen] Unusual light culling(?) behavior

Lights in Lumen seem to be a bit sensitive to placement, if they’re too close to a wall and the light frustum isn’t on screen (I think?) it seems like the light will just get completely culled when the camera pans away. Rotating the light so that the frustum is in view of the player solves the issue, but it can also be solved by simply moving the light an additional 10cm from the wall.

Video of the issue (note that the light is already 10cm~ from the ceiling)

I guess the solution would be to just make sure the light is always a minimum of 20cm from a wall. Just wondering if this is by design.

1 Like

I’d file a bug report over that one… that doesn’t look right at all.

Lumen seems to do some selective switching from ssgi to tracing lumen scene based on occlusion maybe.

There are some sample radius parameters for ssgi and irradiance caching and I think if samples are too small or occluded they become ignored for lumen scene. This is probably to avoid light leaking and sampling small bright spots from distance which could produce flickering.

Lumen seems to be excellent in cases as demoed by Epic (natural, chaotic scenes that hide artifacting well) but it kinda falls apart when you introduce smooth shapes and sharp corners that need to keep those man made shapes looking good.

Maybe someone finds out how to set it up to some extreme quality but I’m kinda worried that as long as there is screenspace solution thrown in the mix it will be problematic.

This looks more like an exposure issue to me, though not sure. In your postprocess volume, try setting your metering mode to ‘auto exposure basic’. I’ve had situations where the histogram will actually dim in darker areas.

I have exactly the same issue, by playing around with the exposure you can reduce this weird effect, however the main problem will still excist. When you turn away from a spotlight or pointlight the scenes becomes darker, sometimes more sometimes less but it’s 100% noticeable.

This is not an exposure issue, the light is turning off. The first thing I do in the video is set the viewport to a fixed exposure.

Yep, you’re right. I missed that part on first watch. Apologies.

So, you might have figured this out already, but I’ve been playing around with this more and found out that this happens when you move outside of the light’s attenuation radius whilst you’re facing away. The reason this spot light did not disable when you turned it slightly was because you turned the cone radius back onto the spot you were stood on. I think anyway.

So looks to me like the workaround, for now, is to increase the attenuation / cone radius of a light. This isn’t great of course, because doing that increases the likelihood of lights overlapping and eating up performance.

It seems that ue5 does not have a new lighting culling scheme for lumen.

For global lighting, the culling of these lights should be different.

vxgi has a similar problem and we can fix this by changing the source code of the engine.