Lit/Unlit Material

I have a media texture that I feed to a material. I need it to be non-modified, so no post-process effect, shading, lighting, etc should be applied to it. My material is Unlit (Emissive).

The color are modified in the game and the image is washed away. The details are blurred. The only way I can get the same as what I see in the texture editor is when I put the game in Unlit mode using F2.

Here’s 4 pictures. The first one (on the left) is the texture editor, and the one on the right is what shows in the game. This is in Lit Mode (F3). The floor colors are blurred (see the details on the yellow line disappear).

Next 2 pictures are in Unlit Mode (F2). As far as I can tell, they are identical.

My question : is there a way to disable all effects on a material?

Thanks,

Hello 3dids,

I have been experimenting with the Media Asset and how it can be applied as a material in the world. Firstly, depending on if your object is large or small can have an overall effect on the images resolution. For example I set up a scene using a plane that was scaled to resemble a large widescreen canvas. I then took my ‘Default Lit’ material that I created using the ‘Media Texture Asset’ and applied that to the canvas screen.

I have provided some screenshots to show you how I implemented this in my level. You can mess around with the properties of the media material, like changing it to unlit and using strictly the emmissive. Try out the settings I have suggested to see if you can get your desired results. If you change your material to unlit then it will act as an unlit object in your scene.

Default Lit Material with Emissive

Material Applied to Plane in Level

I hope this helps, but if you are still unsure as to how to resolve your issue we can investigate further.

Thanks,

Andrew Hurley

Hi Andrew,

Thanks for your answer. I’m using something like you proposed right now. It’s better than letting the default settings working.

What I am really looking for is to get the exact movie playing in my game, unaffected by anything. When playing the game in the editor with the texture viewer opened, please try toggling between F2-F3 (Lit and Unlit mode) when your material is set to Unlit and the texture sample is pluggin the emissive color pin.

There are big difference in my videos, espcially whit the whites. Perhaps the way to do it is to write a custom shaders that would by applied at the end of the post-process, like a menu?

Thanks,
Bryan Villeneuve

Hey Bryan,

So after doing some more fiddling with the materials and trying to understand what it is that is actually affecting the change, I was able to confirm it was the post processing that was causing the distortion. If you type ‘showFlag.PostProcessing 0’ into the command console you can see the visual change of your material. There are a few workarounds to fix this issue.

The first one, and more explicit example, would be to add another post process volume with its bounds within the range of the viewer watching the video in the game to effectively nulify, or reverse, the global post processing.

The second suggestion would be to set up a new material using a Multiply and a Power node. Connect constant vectors to these nodes and convert them into Parameters. One parameter value will control the Brightness, and the other will control the Contrast. Apply this material to your object, and toggle between Unlit and Lit mode, adjusting the material until you get them to match. This will not be perfect, but will get you close to you desired outcome.

Media Material Parameters

Cheers,

Andrew Hurley

Hi Andrew Hurley.,

Thanks, for the answers, I’ll try that and let you know,

Bryan

Hi Andrew,

First, Happy New Year. All the best.

I went back to my color problem after some vacation, and I found that anti-aliasing and Tone Mapping are what’s causing me troubles. So I’ll try to find a way to make the object in my game “untouchable” by antialiasing and tone mapper.

thanks,
Bryan

Thank you so much!

I thought it was a normal behavior of the sky-light or the influence of the atmospheric fog and I really didn’t get it fixed.
Turns out that I had to deactivate the post-processing, as you said, to fix the whole problem. Now everything seems fine. =)

Have a nice week! =)

Hello, how do you deactivate the post processing ?

Thank you for the answer, helped a lot.

@skeleton60 for how to disable post processing check out: How to toggle post process - Programming & Scripting - Unreal Engine Forums