Lightning setup for in- and outdoor game scene

Hi, I try to make a small map for a demo and I need in and outdoor scenes in one map.
The Problem is that there is no light bounce (i think) and it doesn’t look real or good with a skylight applied.
And another thing is that the “Eye simulation” is too strong.

That is my testing map:


-To change the EyeAdaptation: PostProcess (volume placed in the level, or the one on the camera)->Settings->AutoExposure (adjust Min and Max Brightness, set it to the same value to disable the effect)

-To enable GlobalIllumination (bounced light): PostProcess->Settings->GlobalIllumination

-To adjust some Lightmass settings: WorldSettings->LightmassSettings

Note that GlobalIllumination is only working for built lighting!

You could also place LightmassPortals to the windows to tell the engine to spawn more rays there.

How much does the global illumination effect the balance with the auto exposure?

I’m creating scenes like this

and the balance between the shadows/dark areas facing away from the directional light and the global illumination is tricky. Any tips on the dynamic balance between the auto exposure, skylight and directional light would be appreciated.

The AutoExposure worked, the rest didnt. And i build the light.

@MikeRPG Strange thing about your photo. At first glance. I thought I seen a sasquatch wearing an Buttocks hat trying to climb a rock. LOL. Must be the shrooms.
I never did anything planetary, but if I did I would use a constant to ramp over distance. I’m not sure I would apply it to something emmisive. If that’s what the Purple sun, or moon is.
It would definitely help the asteroids come into focus. I’m not sure what it would cost though.
Scroll down to Distance Based Detail Texturing.

What’s the difference between doing that and adjusting the LOD texture and shader options. Purple star, maybe need to add some flares so it doesn’t look like a moon.

@mikerpg I couldnt tell with an asteroid in front of it. You could control whatever materials you wanted by distance. Details by distance could make a player explore if they could only see things at 60 60-70 yards in game, and then things would start to clarify. You could make some stars fade out, and asteroids go from being unseen to visible at a certain threshold. It would depend on how you wanted to play with it, and what you wanted to ramp over distance. If you had a nebula cloud, and some single stars you could use emissive node to make them brighten as someone started approaching them closer. If you wanted to get deep into level design, and there was a planet you wanted someone to notice, and fly too for example. You could have a jupiter like planet with several moons start to brighten. You could do this with pick up items so that people notice them. Say your game has artifacts scattered around, and when someone gets close to them you want them to have emissive glow. The way that light moves guides players. If you were wondering around in a game, and seen light in the horizon would you walk away from it? You could also use the depth fade node.

@thadkinsjr it’s funny you mentioned that as I’m using lights as my main source of navigation. However, I still don’t get the necessity of the detail texturing.

Distance Based Detail Texturing:

“When dealing with large surfaces, such as terrain, you will notice that even though the Textures you are using might tile”

the issue isn’t the tiling of the textures. (sorry for hijacking your thread Ezy)

What do you exactly mean by that? I’m pretty sure that GI and the WorldSettings are functioning properly?

What is your issue exactly? What kind of lights do you have in your scene and with what settings? Show us your WorldSettings and PostProcessSettings as well.

I just had the directional sunlight. and I changed the options you mentioned and tried for like an hour to get it to work.
But i couldn’t see any changes after baking the light.

And i have some issues when using skylight (all textures are seamless)

That looks like the skylight fighting with a directional light. Can you say exactly what lights you’re using and what major settings you are using (stationary, movable, brightness, dynamic shadows/static shadows etc). Try disabling the ambient occlusion and the lightmass settings, make sure lights are stationary not static.

I Just have a:
Sky sphere (everything standard)
Directional Lightsource (Just changed the Color)
Skylight (standard)

I enabled now “Force No Precomputed Lighting” it seems to work, but is that even good?
And how can I turn of AO?

And the shadows outside seem to be too dark, but inside it’s a little too bright.

AO is in the rendering settings, or in a ppv which you aren’t using (but probably should).

I’d add a global post processing volume and experiment with the max exposure to control the brightness.

Worked, thanks.
I Enabled AO in the PPV but nothing happened.

and idk why, but the bottom side of all of my meshes are black (Only when facing to the bottom)

The last part is confusing:

“only when facing to the bottom”

If I have to guess it’s the skylight lower hemisphere setting or an exponential height fog.

Its with all meshes. only the faces that are facing the bottom are black, even if I rotate the mesh.
I try to change some settings in the skylight and fog.

Changeing the Hemisphere color does something, but the shadow get to bright and i dont have exponential height fog