Lightmap Not Producing Expected Results


In advance thanks for any assistance I’m new to using Unreal Engine and am trying to learn the necessities for realistic and clean lighting.

I have a static mesh that I created in Blender with 2 UV channels, one for texturing and one for the lightmap. The lightmap consists of 3 islands, one for the main trunk and one for each branch (see picture). Even with the lightmap resolution set to 1024 (really high as I understand) I am still getting the lighting result shown in the image below.

1st question is as follows: Is my lightmap UV acceptable, being new at all of this I have probably misunderstood articles I have read and created a UV that will never work.

2nd question, If that UV is fine then what else could it be?

take a look at this page

Hi there,

By the looks of it the shadow on the tree itself is fine, the shadow on the ground is what seems to be the problem. If it’s the ground you are talking about then you need to increase the lightmap resolution of the ground asset as opposed to the tree, the lightmap UVs are for shadows which the objects receive itself, it doesn’t affect how shadows appear on other objects.

I hope that helps. :slight_smile:


Thank you @JBroderick for the info, I was thinking about it in completely the wrong way. Now I know that that I’ll have a play with it and hopefully get better results.

Cheers, Jake

Thanks very much for the link @saeedc, there’s plenty of helpful info on that page.

Cheers, Jake

You’re obviously using a directional light, most likely attached to a sky sphere BP.

Try this:

  1. Select your directional light in the object list to the right and make sure it’s Mobility is set to “Moveable”. Not static or stationary.

  2. While your directional light is selected, scroll down and raise the “Shadow filter sharpen” number from 0. to 0.5 or so.

  3. Scroll down further and uncheck “Cast static shadows”.

  4. Make sure “Cast dynamic shadows” is checked.

If you’ve placed your tree as a static mesh by dragging and dropping it on the terrain, select it then check dynamic shadows, uncheck static shadows.

If you’ve placed it via the foliage tool, go back to the foliage painter tool and highlight the foliage type, scroll down and check dynamic shadows, uncheck static shadows.

If the tree is a blueprint, open the blueprint, select the static mesh component, uncheck static, check dynamic.

You’re tree should now be casting a fairly accurate dynamic shadow.

Good luck.