Knowledge Base: Using Audio Capture Component for Mic Capture

Sep 3, 2021.Knowledge
Article written by Anna L.
What is Audio Capture Component?
The Audio Capture Component offers a method of capturing mic input during gameplay. When activated, it will retrieve and play back mic …

https://dev.epicgames.com/community/learning/knowledge-base/Oak2/unreal-engine-using-audio-capture-component-for-mic-capture

7 Likes

This option doesn’t exist

1 Like


Just search for it.

I have tried to use your “Quick Start” guide.
However, I wasn’t able to hear myself.
I have tried to bind “On Audio Envelope Value” to see any output as float, but nothing (float value 0.0, while debugging).

I saw some articles about enabling [Voice] in DefaultEngine.ini project config (did not help either).

I tried to use released 5.0.3 version, then I tried one I build by myself (from sourcecode) with no avail.

I am on Ubuntu 22.04, what config do I need so Unreal recognize my Mic input ?
(Pulseaudio don’t see any new application with Unreal start.)

I am also on Ubuntu 22.04 and cannot get audio capture to work at all.

I have added the AudioCapture component to an actor, always enabled. I have added the [Voice] section to the .ini file. I have tried on 5.0.3 and 5.1.0_preview2.

The troubling output is:

LogAudioCaptureCore: Display: No Audio Capture implementations found. Audio input will be silent.

I’m not really sure how to move forward with this. The check is here:
https://github.com/EpicGames/UnrealEngine/blob/c3caf7b6bf12ae4c8e09b606f10a09776b4d1f38/Engine/Source/Runtime/AudioCaptureCore/Private/AudioCaptureInternal.h#L33-L47

But I’m out of my depth understanding what is in the ModularFeaturesMap and how it gets populated on a given operating system.

1 Like

I can’t get this to work either on Mac OS 12.6, ARM. Have tried to add an AudioCapture component as above—I also tried enabling the take recorder and adding a microphone input, but in the output log I get the following on record:

LogTakesCore: Error: Microphone Audio Source could not start. Please check that the AudioCapture plugin is enabled

The plugin is enabled, however. I’ve tried with 5.0.3/5.1 preview 2 binaries, and 5.1 arm built from source.

1 Like

Quick update on this: if I build a project, and edit the project’s .plist per this thread , then when I open the project build it properly asks for microphone permission and AudioCapture works correctly. I never get this system request for mic permission when playing in editor.

OK, I think, it is time to create a bug report for this AudioCapture component, after i can see i am not alone.

1 Like

The same thing is happening to me when I export to linux and android… unfortunately the audio component seems to only work on windows.
It doesn’t work on linux, nor on any android emulator.
And I see that it doesn’t work on IOS either
It seems that this component lacks quite a bit of work.
In my case I am testing on emulators, but it doesn’t work on any of them.
And I can say that the emulators take the microphone, because if I download an APP from the playstore to record voice, it works perfectly.
The audio component does not activate the microphone on Android.
and it doesn’t work on linux with Steam.

1 Like

Can you submit bug report, too. With this video, too ?
More reports bigger the chance of a fix.

Yes, I will have to.

1 Like

I found the solution and wrote it in this post.
For AudioComponent to work on Android, you have to give it permissions from Android.
I leave the link.

Maybe this helps?
Microphone not working on Quest 2 - Development / Audio - Epic Developer Community Forums (unrealengine.com)

Hi there, I’m facing the same issue in Windows Build.
Could you help me solve the problem?

Thanks