Issue with material? Why does one foliage type become so overly dark when facing away from the light source, whereas another not respond at all?

I’m still somewhat new to unreal, and have been following this wonderful [tutorial][1] to create a simple medieval scene. I deviated a bit since I’m looking to build more of an actual game where you can run around (rather than just a static scene), and I was going for a different lighting effect and overall mood (something a bit more vibrant and game-like). But overall, I’m quite pleased with how it’s turning out so far.

However, there’s one issue I’m not quite sure how to go about figuring out. I’m using some grass foliage from Quixel, and I’m finding that there are some grass types that seem to respond too aggressively to light, whereas others hardly respond at all. I’m guessing it’s an issue with the material, but I’m not sure how to go about troubleshooting or correcting it.

Here is what the grass looks like when it is directly lit:

And here is what it looks like after turning the camera:

Notice how jarring it looks - when used at high density, the grass appears almost black when facing away from the sun.

What’s interesting is another grass type from the same asset pack seems to have the opposite problem, and hardly responds at all. I put together this simple level to compare, and also shows the scene setup / lighting I’m using:

It appears not to matter what the density is, or whether it’s placed via foliage tool or directly as a static mesh - just including all that to rule anything out.

The “Thatching Grass” asset is this one from quixel:

And the “Lemon Grass” asset is this one, also from quixel:

Both grass types actually use the same material instance, but obviously with different albedo, normal, opacity and roughness textures. Here is the output when looking at the “Overview” buffer visualization, in case it helps with analyzing this:

Why would these two grass types behave so differently with respect to lighting? And how can I go about fixing the thatching grass so the change isn’t quite so extreme (and maybe also tweak the lemon grass so it actually responds a little bit more to changing light)?

1 Like

Can you show me the material as well as the settings? Seems like a subsurface issue, namely that there appears to be no SS effect at all.

Here’s some grass WITHOUT SS, as you can see it has the same shading issue:

Here is it with SS enabled:

I see a couple of minor errors that you may want to fix:


The issue does seem to be SS. I’d say the reason you’re having such issues with SS is because IMO, the translucency textures provided by Quixel aren’t so great. Check out the extreme difference in brightness with the translucency textures:


That will give you WILDLY different results with the very same SS settings. The lemon grass appears fine because it’s receiving more SS influence because the colors are brighter. What I personally do is use the albedo textures to drive SS. You really don’t need the translucency textures. Albedos are far more consistent in terms of shading and darkness levels:


The bright translucent effect is probably happening because you have to ramp up the SS strength so much due to the translucency texture being so dark.

Oh wow, that made a real big difference, and seems way less hacky:

I’ll need to play around with the billboard version of the material, since it has a much darker albedo, and the same technique makes it look kind of gray (not depicted above). But that I think I can figure out by tweaking the textures. Thank you greatly for the help!

Sure - both grass varieties have their own material instance, which is then tied to the Quixel Megascans “Foliage Master Material”. Here is an overview of the master material:

And then just zooming in on the Translucency section (the output of which is connected to Subsurface Color on the output node):

Then here is the material instance for the Thatching Grass variety:

I tried playing around with the SSS Color Tint and Intensity settings, and it does seem to have the desired effect. I set the SSS color tint to roughly match the wheat color when it is directly lit (sRGB DBDAC9FF), and bumped the SSS Color Intensity way up to 100 (it only seems to have enough of an effect if I set it ridiculously high). I also set the normal intensity up a bit higher as well to compensate, just to get more of the shadows back:

That seemed to have the effect of making the grass look a bit fluorescent - but I think I can compensate for that by messing with the albedo? I’ll try tinkering with this some more, but I think you set me on the right path. Subsurface scattering does seem to be the property to tweak.