How to enable Chaos

Countdown Timer - Time since Aug 22, 2019 2:00 pm started in Raleigh

Hi BryanBishop,

Here is the topic about the livestream on the UE4 forum : Unreal Engine Livestream - Chaos Fundamentals - August 22 - Live from HQ - Unreal Engine Forums

Then, here is the countdown before the stream starts : Countdown Timer - Time since Aug 22, 2019 2:00 pm started in Raleigh
(the countdown is given by VictorLerp in his message)

See you during the stream,

We announce the livestreams on the Events section of the forums, and we go live on Thursdays at 2PM ET on Twitch and YouTube.

link dont work to get the special version

Is there anyway to get the content examples for 4.23 before the release of 4.23? The video was fair. I would give it a C+.

Come on man, it’s not that hard to read what was written.

nvm had to link the github and epic , hope this never gets hacked either of them caus ehten you open up both to trouble , thats the problem with this kinda stuff…

update 54: ya linking said account also leads to 404 if i click the link on first page…i go up and its nto even in asid repository now…

solved ok ther eis a step missing that i missed and was not in the steps GITHUB sent two emails after you do that where YOU JOIN a github repository to get the build and once you do the join form said email you get access.

so people that dont know your verification email look right before that one for it.

Anybody know howto generate hit or overlap results with geometry collections? They seem to respond only to fields. And for example I can’t make any object stand above a geometry collection.

I downloaded preview 7 from the launcher, I could see all the following plugins and enabled them

  • ChaosEditor
  • Planar Cut
  • Editable Mesh
  • Geometry

Restarted the editor

I can’t seem to get the fracture editor in the modes tab. I guess it only works with the Github release branch code you compile yourself then?

EDIT: Looks like Victor already answered a similar question…

“You’ll have to compile the engine from GitHub to use Chaos until it’s out of Early Access, which will take a couple of engine versions.”

Not sure why we can see / enable the plugins in preview though.

Good question. Would like to know the same. @VictorLerp

I am having the same problem when I follow the instructions here. This is my UE4Editor.Target.cs:

using UnrealBuildTool;
using System.Collections.Generic;

public class UE4EditorTarget : TargetRules
    public UE4EditorTarget( TargetInfo Target ) : base(Target)
        Type = TargetType.Editor;
        bCompileChaos = true;
        BuildEnvironment = TargetBuildEnvironment.Unique;
        bBuildAllModules = true;


Once compiled, when I start UE4Editor.exe the following occurs. The error is always the same - highlighted in bold. (I’ve been trying to follow this thread and make this work since preview 4). Maybe its just best to wait for final release.

Fatal error: [File:C:/Users/max/Documents/GitHub/UnrealEngine/423/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp] [Line: 836]
Rendering thread exception:
**Assertion failed: !bInitializedSerializationHistory [File:C:/Users/max/Documents/GitHub/UnrealEngine/423/Engine/Source/Runtime/RenderCore/Private/Shader.cpp] [Line: 168]**
Shader type was loaded after engine init, use ELoadingPhase::PostConfigInit on your module to cause it to load earlier.

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION writing address 0x5327cde8

0x00007ff9e27d5eb7 UE4Editor-RenderCore.dll!FRenderResource::InitResource() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\RenderCore\Private\RenderResource.cpp:82]
0x00007ff9e28376ab UE4Editor-RenderCore.dll!TGraphTask<TEnqueueUniqueRenderCommandType<`BeginInitResource'::`2'::InitCommandName,<lambda_ca51434da6012349da95a9abb2880eb9> > >::ExecuteTask() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Public\Async\TaskGraphInterfaces.h:847]
0x00007ff9c2255465 UE4Editor-Core.dll!FNamedTaskThread::ProcessTasksNamedThread() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:686]
0x00007ff9c2255813 UE4Editor-Core.dll!FNamedTaskThread::ProcessTasksUntilQuit() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:583]
0x00007ff9e286fd6b UE4Editor-RenderCore.dll!RenderingThreadMain() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp:340]
0x00007ff9e287834e UE4Editor-RenderCore.dll!FRenderingThread::Run() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp:471]
0x00007ff9c26a863f UE4Editor-Core.dll!FRunnableThreadWin::Run() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:96]
0x00007ff9c269ec11 UE4Editor-Core.dll!FRunnableThreadWin::GuardedRun() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:53]
0x00007ffa32f57974 KERNEL32.DLL!UnknownFunction ]
0x00007ffa3569a271 ntdll.dll!UnknownFunction ]

You should do:

public class UE4EditorTarget : TargetRules
public UE4EditorTarget( TargetInfo Target ) : base(Target)
Type = TargetType.Editor;
BuildEnvironment = TargetBuildEnvironment.Shared;
bBuildAllModules = true;

bCompileChaos = true;


The difference is: “TargetBuildEnvironment.Shared”

Still no fracture editor in P8.

Unless I misread awhile back in this thread, Chaos will not be available via the launcher in 4.23. You must compile from source to use it until it’s officially released in a later version. Don’t quote me on this, though. :wink:

You are absolutely right. When Chaos comes out of its experimental state it will be part of the launcher. Until then you will always have to compile the version to be able to use it.

I would definitely expect to need to compile it in 4.24 and 4.25, too.

So, the GitHub link points us to 4.22.3 not 4.23. Which one is the correct one?

I did a simple “linear regression analysis” for 4.25. Did not control all variables. I will be about 150 by then(ha,ha). I am getting good at compiling the source.(P3-P8). What I really would like is the content examples that has Chaos. Oakman had it in the video. Put the project in P9. I get the CubeStack created then the GeoCollection. Then cannot do the next step. Has anyone that does not work for Epic accomplished this. Please do a video. Use OBS it is free.

@theProfessor Have you enabled the Fields plugin?

@theProfessor The Content Examples project is separate and not found at GitHub, which is only the engine code. The Content Examples is found at the Learn tab at Epic’s Launcher (you can see the latest one there up to UE4.22). Once the UE4.23 releases the project will receive an update marking it as 4.23 compatible and the examples with Chaos will be there, not in preview unfortunately.

Yes, I have enabled the Fields system.