Download

How to enable Chaos

**Update: 4.26-Chaos Preview build in Epic Games launcher enables Chaos by default - details here

Follow these steps to enable Chaos (engine source documentation)

4.24 NOTE: **You have to add both of these lines to your UE4Editor.Target.cs file:

bCompileChaos = true;
bUseChaos = true;

**NOTE: **This will enable Chaos for all of your Blueprint and C++ projects. If you’d like to enable Chaos per project, you will have to add the new target lines to your project’s Target.cs file and create a C++ project (it won’t work with a Blueprint project).

Follow these steps to open the Chaos Destruction Demo:

  1. Download the Chaos Destruction Demo from the Learn tab on the Epic Games Launcher.

  2. Download Unreal Engine from Github (source build is required until Chaos is out of Beta).

  3. After you setup your GitHub build (you don’t need to compile it), move the ChaosDestructionDemo folder into the same folder that you unzipped the GitHub build to.

  4. Run GenerateProjectFiles.bat.

  5. Open the created UE4.sln.

  6. Build the ChaosDestructionDemo for Development Editor (should be the default Visual Studio configuration). This will build the whole engine, with Chaos, since it’s already setup in the project’s Target file.

**NOTE: **If you want to create your own project, you will have to follow the steps outlined in the “Follow these steps to enable Chaos in 4.23” section.

  1. Once it’s done, you can launch the sample from Visual Studio with F5 (or Ctrl+F5, which will launch without debugging attached).

NOTE: If you don’t have the Epic Games launcher installed, this will be the only way you can launch it. Double-clicking the ChaosDestructionDemo.uproject will not work (you’ll get an error message).

  1. If you do have the launcher installed you should be able to open it by double-clicking the uproject.

Break all the things!

**RESOURCES:

Chaos Documentation

https://youtube.com/watch?v=hx9dHgcN0bE
https://youtube.com/watch?v=iFKzXnIiH50
https://youtube.com/watch?v=mwbSi2R49ZY**

Feel free to use this thread for discussions related to Chaos. We appreciate your feedback!

Will it work with blueprint only projects at the final release ?

In Step 3, I can’t find a plugin called Editable Mesh or Geometry. For ChaosEditor and PlanarCut, everything seems to already be set to true… except for “Installed,” which is set to false.

ohhh those look fun, I can’t wait to try it out!

Is it just me, or fractured geometry collection objects are not getting simulated? They just hang on air…

Will this change anything regarding PhysX as we are actually turning on Chaos? or just using it as a plugin for fracture and threaded destruction at present.

Not having any luck adding this. Would you be able to post what your UE4Editor.Target.cs file looks like?

Thank you,

PatS

same for me.

@VictorLerp do the three plugins, that you have listed as requirement (Planar Cut, Editable Mesh and Geometry), have anything to do with the new advanced programmatic mesh features that we can see on trello?

I built you with Chaos enabled as described, but it crashes when I start the engine.
It looks like the shaders are not loaded, but do you need anything else?

​​​​​​​

> I built you with Chaos enabled as described, but it crashes when I start the engine.
> It looks like the shaders are not loaded, but do you need anything else?

This issue will be raised by loading WindowsMixedRealityPlugin at PostEngineInit phase. Normally it will be loaded at PostConfigInit.
You can set EnableByDefault true in WindowsMixedRealityPlugin.uplugin to fix it temporarily.

I am trying to use Chaos witn 4.23.1. Installed from the launcher. Will Chaos work with the 4.23.1 from the launcher? When I create geometry collection and then click on it Unreal crashes.

It won’t work from the version at launcher. You need to build the engine by source as the steps on the 1st post, and if you are not familiar with source build I recommend for you to wait when 4.23 releases.

I just loaded into Github. Where is 4.23 source? I did compile 4.10. And it worked. It was a while ago.

With the page from GitHub opened with Unreal Engine 4 repository, you need to select in the combobox called “branch” the value: 4.23 at the dropdown list. Once you select that you can clone or download as zip file and follow the build process described in the front page of the repository. Minimum Visual Studio release supported is the VS 2017, it is not necessary build with VS 2019.

This worked for me! Well, kind of. So everything is loaded, Chaos Solver is in the scene by default, I can create geometry collections, I can fracture, etc. etc. BUT… the geometry collections just seem to be stuck in space… they have no collision, no gravity, no mass. Also, in the video by @AlanNoon at GDC, there seemed to be a slider in the fracture menu that let you preview pulling the fracture apart… as far as I can tell that’s not in the preview.

Anyone know how to get Chaos Destruction working?? I’d be perfectly happy to start by just seeing a cube fall from the sky and break apart when it hits the ground.

I have updated the post with what the UE4Editor.Target.cs should look like, and revised a line that wasn’t necessary.

I have the first person project started and while i was able to fracture the objects, I haven’t been able to interact with them, via shooting. What else do we need for this workflow?

Oh yes, it works for me now. Managed to convert static meshes into fractured geometry. The mystery now is how to properly set up collision and trigger destruction?

I got it working, but I don’t know what I did to get it to work.

all I did was enable some extra plugins, mess with some editor and project settings and messed with the geometry collection settings in the details pane.

edit: it could be that you had to enable the “blast” plugin.