Download

How to enable Chaos

I got it working, but I don’t know what I did to get it to work.

all I did was enable some extra plugins, mess with some editor and project settings and messed with the geometry collection settings in the details pane.

edit: it could be that you had to enable the “blast” plugin.

I enabled the Blast plugin… still no dice. If you can figure out how you got it working it would be much appreciated! thank you.

try these:

Thanks-- those didn’t work, but this did: change Default Threading Model to anything except Task Graph.

I’ve followed all steps but still editor crashed when tried to generate Geomerty Collection.
I’m using Windows 7 SP1.
It has a different DirectX 11 version from Windows 10’s.
Does anyone can touch chaos with Windows 7?

i had no luck with it either on windows 7, did not try on windows 10…

I think we still have missing information… How do we make anchors and fields?

It only has 4.0,4.1,4.2,4.3,and 4.4.

Are all the ones that has a fatal error when creating geometry collection are on windows 7?
will it not crash if i will switch to windows 10?

I am getting the same error in Windows 10.

If you scroll down the list at that combobox there are all the way from 4.0 to 4.23 plus all the modules in separate aswel. You have to click on the “Branch: release” button, not the link called “branches”

Does someone has a fix to share, in order to not crash the editor when creating geometry collection?

I downloaded UnrealEngine-4.23-preview-1. zip. Is this the right one? After using “setup.bat”. I get this error

The error is because your Visual Studio 2017 installation misses some components and/or is not updated to the latest release. Since there is quite some time I don’t do such type of install I might miss some info, looking for a tutorial would be best, but if my mind doesn’t fail me, these components must be installed (execute Visual Studio Community 2017 install and click on Modify Button):

  • .Net Core Cross Platform development
  • Game development with C++
  • .Net Desktop development (probably not)
  • Universal Windows Platform development (probably not)

Once the components download and install, you try to execute the setup.bat again.

Seems to be working … but pieces dont sim - just hang in air. And having difficulty understanding how to use fields to apply forces… anybody know of any examples?

Has someone got it working on a windows 7?

There’s nothing in particular that blocks Chaos on Win 7. You should submit a bug report with your crash log (and post it here as well) so that we can identify if there are any issues with Win 7.

I have 4.23 preview 2. Does not crash but I don’t see any geometry collection? I have the geometry collection plugin enabled, but when I right click I don’t see it.

Did you download from Github?

From the launcher. I have been trying for 2 days to it to work from Github with no success. Have done it(preview 2) from Github?