Help with Custom Foliage Importing from 3ds Max

Hi, I was hoping I could get one of the community members knowledgeable in 3DS Max and importing trees/foliage to UE4.

Here is the issue I am having. And I believe my problem lies in Max but their forums are awfully slow these days. This is my plane with my Leaves which is a handrawn texture and Alpha. Both are imported as .tif to Max. The material looks correct in the editor and it renders fine but for some reason its exporting the alpha channel?

This is what I am getting inn UE4

Any help would be great. Thanks :slight_smile:

You’ll probably want to look in your 03_-_Default material and make sure that the texture is feeding the proper channels to the proper pins, i.e. the main mix channel needs to be plugged into the diffuse pin and the alpha channel needs to be plugged into the opacity mask pin.

Thanks for the reply!

Yes I needed to set up the material. I just figured it out and was coming here to post. lol

For anyone else, I had to switch the material blend mode to translucent and connect the alpha to the opacity(Only available if you switch blendmode)

Thanks again for the quick reply.

Change blend mode to Masked.
And change Shading model to 2 sided.

Hope that helps. :slight_smile:

Edit: After shading model is set to 2 sided you need to connect your diffuse to the Sub Surface Scattering slot as well.

HA, so I have a new problem…my planes that I am importing now have turned all scrambled. They look like this now

All i did in make is Shift and rotate planes around. It once again rendered okay in Max but this happened? Any help?

Thanks Max! I’ll definitely do that once I figure this new problem out

Can you show the mesh in max without textures applied to it?
And then with textures applied to it (again in max)?


I hope that’s what you need. Let me know if its not. Thanks Max

Those look the same. It looks like the “mask” level of the cutout is different, though.
Or maybe there is some U/V scaling that doesn’t transfer in the FBX file?

Can you show your material setup in UE4 as well?

So this is how it imports. All Scrambled. This is without me adding material.

This is my material. I know you posted above some changes that are not in this screenshot. I’ll show you what happens when I make those changes.


Plug texture coordinates node into Texture Sample node?

Unfortunately that’s not it but thank you.

It appears its on Max’s end. There must be something I am doing improperly when exporting.

Try turning the mesh into a single editable poly in 3ds max and after that unwrap it.

Still gave me the same results :frowning:

Upload your mesh and textures and PM me.

Side note: When blend mode is set to Masked, the opacity map should be plugged to Opacity Mask slot. Not the Opacity slot.

Okay thanks. I will do that. I did narrow it down slightly to an issue with the plane exporting. Here below on the left you see a plane (With no width or length segments) with the leaf texture on it. On the right is a plane with the texture but it has segments added so I can bend and shape it. It exports all scrambled. It makes me think my settings are screwed or something.

Here is a link to my model to DL if that what you were referring to Maximum.

Sorry. Please save the file for Max 2014.
Meanwhile, others can look into it as well if they can open it.

Done and sent via PM