Having lighting problem when using lumen in interiors on static/skeletal meshes

this problem occurs when using lumen in global illumination and reflections. The meshes get completely shadowed and i cant pinpoint the problem and could use some tips and help.

  • I tried converting these meshes to nanite and it seems to fix them however in meshes that has metallic surfaces like burnished steel it doesn’t work.(In skeletal meshes its a dead end]

  • As shown in one of the image switching to screen space global illumination fixes the problem but looks terrible on high settings.

  • with lumen on and global illumination scalability set to low fixes it but looks terrible

  • I tried changing lightmap resolution, Shadow inset, sphere reflection probe it doesn’t work only ting that works is either disable lumen or set global illumi. to low which looks terrible

You should look at the documentation on lighting and the pages on Lumen and Nanite. For example, neither Nanite or Lumen work with skeletal meshes and for interiors there’s some special considerations that need to be kept in mind. I imagine you likely need to look at some general stuff about lighting as well.

1 Like

alright ill take a look