Download

Generate cpp project Couldn't find UnrealBuildTool

I have problem with generate cpp project


But in DotNET isnt exe file but UnrealBuildTool folder
image

4 Likes

having the same issue. tried to Verify but didn’t work either :frowning:

For now, i had to copy the contents from the UnrealBuildTool folder to the DotNET folder…

1 Like

after copy

Running E:/unrealEngine/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“E:/unrealProjects/Mag/Mag.uproject” -game -rocket -progress -log=“E:\unrealProjects\Mag/Saved/Logs/UnrealVersionSelector-2021.05.26-23.04.54.log”
ERROR: Unhandled exception: System.IO.DirectoryNotFoundException: Could not find a part of the path ‘E:\unrealEngine\Engine\Source’.
at System.Environment.set_CurrentDirectoryCore(String value)
at System.Environment.set_CurrentDirectory(String value)
at System.IO.Directory.SetCurrentDirectory(String path)
at UnrealBuildTool.UnrealBuildTool.Main(String[] ArgumentsArray) in d:\build++UE5\Sync\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.cs:line 467

1 Like

I have the same problem… Seem that the hierarchy used in UE5 is different since it store the UnrealBuildTool.exe in its own UnrealBuildTool folder. I tried many things like moving everything in the subfolder in the DotNET and it gives a post execution error.

Also tried adding a path variable, checking the installation, just moving the .exe alone and using cmd and nothing seems to work.

UBT for the moment just works by doing it through the editor.

I will try some more stuffs but this is a big let down for the moment

1 Like

For this problem i created a symbolic link that maps to the Engine folder.

My install location is C:\Program Files\Epic Games\UE_5.0EA

I created the sym link in *C:\Program Files\Epic Games* with mklink Engine UE_5.0EA\Engine

This is very meh, but i just wanted to open the editor xD

ok
UnrealBuildTool.exe -projectfiles -project=“E:/unrealProjects/Mag/Mag.uproject” -game -rocket -progress

run from cmd work

6 Likes

To get the engine files in your solution you need to add -engine.

UnrealBuildTool.exe -projectfiles -project=“C:\UnrealProjects\ProjectFolder\ProjectName.uproject” -game -engine -rocket -progress

3 Likes

Same issue. All of the suggestions above didn’t solve the problem.

I also had to install dotnet 3.1.something runtimes to get it working via command line (even though I had no issues with missing runtimes for UE4)

Me too

Same issue here,
Now after installing Dotnet 5.0, 3.1, Visual Studio 2019 and using the command line I get this:

ERROR: Unhandled exception: System.Exception: Unable to find project file based on argument C:\Users\Schnittbrot\Documents\Unreal Projects\Pariser_Platz_5.0\PariserPatz.uproject
at UnrealBuildTool.GenerateProjectFilesMode.TryParseProjectFileArgument(CommandLineArguments Arguments, FileReference& ProjectFile) in d:\build++UE5\Sync\Engine\Source\Programs\UnrealBuildTool\Modes\GenerateProjectFilesMode.cs:line 302
at UnrealBuildTool.GenerateProjectFilesMode.Execute(CommandLineArguments Arguments) in d:\build++UE5\Sync\Engine\Source\Programs\UnrealBuildTool\Modes\GenerateProjectFilesMode.cs:line 83
at UnrealBuildTool.UnrealBuildTool.Main(String[] ArgumentsArray) in d:\build++UE5\Sync\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.cs:line 565

Same exact issue for me

Might have a solution. After going through the SLN file of a new UE5 code project (create a new code project from the launcher), I saw that there wasn’t really much to it, just seems to be references to a bunch of folders and such, so I compared it to my UE4 one, the only difference is the reference numbers (which I assume are engine specific) and a reference to the project name.
I copied the new one to my project, moved my old one to desktop and then renamed the new one to the original name, opened the SLN with word and changed the project name (hilighted green in the picture) and then saved/closed. Double clicked it and VS opened with the project right away.
Now I just have to go through my .Uproject and change the engine association in it from “EngineAssociation”: “4.26”,
to
“EngineAssociation”: “5.0EA”,
Set all 3rd party plugins to “false”
Here’s the raw code that you can paste into your SLN file, you just have to change the project name 2 times on line twelve (12) or eleven (11) Different text editors show an extra line up top. Change “ShadowWars” to your projects name.
Still unclear on how to get “UE5” to show in VS, but this is progress at least for me.
Edit: overwrite everything in your SLN file with this code, don’t leave anything from the original.

Microsoft Visual Studio Solution File, Format Version 12.00
# Visual Studio Version 16
VisualStudioVersion = 16.0.28315.86
MinimumVisualStudioVersion = 10.0.40219.1
Project("{2150E333-8FDC-42A3-9474-1A3956D46DE8}") = "Engine", "Engine", "{233774A8-CC9D-3FA9-86D1-90573E92B704}"
EndProject
Project("{2150E333-8FDC-42A3-9474-1A3956D46DE8}") = "Games", "Games", "{DE1F8B53-6C02-3C13-9101-A7C8D96F3FF6}"
EndProject
Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "UE5", "Intermediate\ProjectFiles\UE5.vcxproj", "{84BC08E9-3996-3C61-846C-1DC763A9A7FE}"
EndProject
Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "ShadowWars", "Intermediate\ProjectFiles\ShadowWars.vcxproj", "{D22450D3-56DD-33E3-94CA-71C72ACB00BC}"
EndProject
Project("{2150E333-8FDC-42A3-9474-1A3956D46DE8}") = "Visualizers", "Visualizers", "{1CCEC849-CC72-4C59-8C36-2F7C38706D4C}"
	ProjectSection(SolutionItems) = preProject
		..\..\..\..\..\Program Files\Epic Games\UE_5.0EA\Engine\Extras\VisualStudioDebugging\Unreal.natvis = ..\..\..\..\..\Program Files\Epic Games\UE_5.0EA\Engine\Extras\VisualStudioDebugging\Unreal.natvis
	EndProjectSection
EndProject
Global
	GlobalSection(SolutionConfigurationPlatforms) = preSolution
		DebugGame Editor|Win64 = DebugGame Editor|Win64
		DebugGame|Win64 = DebugGame|Win64
		Development Editor|Win64 = Development Editor|Win64
		Development|Win64 = Development|Win64
		Shipping|Win64 = Shipping|Win64
	EndGlobalSection
	# UnrealVS Section
	GlobalSection(ddbf523f-7eb6-4887-bd51-85a714ff87eb) = preSolution
		AvailablePlatforms=Win64
	EndGlobalSection
	GlobalSection(ProjectConfigurationPlatforms) = postSolution
		{84BC08E9-3996-3C61-846C-1DC763A9A7FE}.DebugGame Editor|Win64.ActiveCfg = BuiltWithUnrealBuildTool|Win64
		{84BC08E9-3996-3C61-846C-1DC763A9A7FE}.DebugGame|Win64.ActiveCfg = BuiltWithUnrealBuildTool|Win64
		{84BC08E9-3996-3C61-846C-1DC763A9A7FE}.Development Editor|Win64.ActiveCfg = BuiltWithUnrealBuildTool|Win64
		{84BC08E9-3996-3C61-846C-1DC763A9A7FE}.Development|Win64.ActiveCfg = BuiltWithUnrealBuildTool|Win64
		{84BC08E9-3996-3C61-846C-1DC763A9A7FE}.Shipping|Win64.ActiveCfg = BuiltWithUnrealBuildTool|Win64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.DebugGame Editor|Win64.ActiveCfg = DebugGame_Editor|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.DebugGame Editor|Win64.Build.0 = DebugGame_Editor|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.DebugGame|Win64.ActiveCfg = DebugGame|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.DebugGame|Win64.Build.0 = DebugGame|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.Development Editor|Win64.ActiveCfg = Development_Editor|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.Development Editor|Win64.Build.0 = Development_Editor|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.Development|Win64.ActiveCfg = Development|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.Development|Win64.Build.0 = Development|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.Shipping|Win64.ActiveCfg = Shipping|x64
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC}.Shipping|Win64.Build.0 = Shipping|x64
	EndGlobalSection
	GlobalSection(SolutionProperties) = preSolution
		HideSolutionNode = FALSE
	EndGlobalSection
	GlobalSection(NestedProjects) = preSolution
		{84BC08E9-3996-3C61-846C-1DC763A9A7FE} = {233774A8-CC9D-3FA9-86D1-90573E92B704}
		{D22450D3-56DD-33E3-94CA-71C72ACB00BC} = {DE1F8B53-6C02-3C13-9101-A7C8D96F3FF6}
	EndGlobalSection
EndGlobal

1 Like

Don´t understand it , can you explain it a bit better how i get it fixed?

Use something like

“D:<your install folder>\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.exe” -projectfiles -project=“D:\DNATG\UE5\ValleyoftheAncient\ValleyoftheAncient.uproject” -game -Engine -rocket -progress

should work

You need to start Windows Command Prompt

Then go to the drive UE5 is installed on, for me it was G
Typed g:

Then go to the directory where UnrealBuildTool.exe is located.
cd YourInstallFolder\Engine\Binaries\DotNET\UnrealBuildTool

Then run the UBT
UnrealBuildTool.exe -projectfiles -project=“C:\UnrealProjects\ProjectFolder\ProjectName.uproject” -game -engine -rocket -progress

2 Likes

“D:<your UE5 install directory>\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.exe” -projectfiles -project=“D:<your project install directory>\ValleyoftheAncient\ValleyoftheAncient.uproject” -game -Engine -rocket -progress

Should work

I tried the command line approach using the UnrealBuildTool.exe located in the DotNET\UnrealBuildTool folder. It completed successfully but left me with several errors when trying to build in VS. (listed below)

EDIT: I made ton of files NOT read only and the project built successfully but still fails to load (gets stuck at 75% Exception thrown at 0x00007FFDA32055BA (UnrealEditor-RHI.dll) in UnrealEditor.exe: 0xC0000005: Access violation reading location 0x0000000000000110.)

Rebuild started…
Restored U:\Program Files\Epic Games\UE_5.0EA\Engine\Source\Programs\AutomationToolLauncher\AutomationToolLauncher.csproj (in 37 ms).
Restored U:\Program Files\Epic Games\UE_5.0EA\Engine\Source\Programs\Shared\EpicGames.Perforce\EpicGames.Perforce.csproj (in 185 ms).
1>------ Rebuild All started: Project: EpicGames.Core, Configuration: Development Any CPU ------
NuGet package restore failed. Please see Error List window for detailed warnings and errors.
Error occurred while restoring NuGet packages: Access to the path ‘U:\Program Files\Epic Games\UE_5.0EA\Engine\Source\Programs\Shared\EpicGames.Jupiter\obj\EpicGames.Jupiter.csproj.nuget.g.props’ is denied.
1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(5488,5): error MSB3491: Could not write lines to file “obj\Development\netcoreapp3.1\EpicGames.Core.csproj.FileListAbsolute.txt”. Access to the path ‘U:\Program Files\Epic Games\UE_5.0EA\Engine\Source\Programs\Shared\EpicGames.Core\obj\Development\netcoreapp3.1\EpicGames.Core.csproj.FileListAbsolute.txt’ is denied.
1>Done building project “EpicGames.Core.csproj” – FAILED.
2>------ Rebuild All started: Project: BuildUtilities, Configuration: Development Any CPU ------
2>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(5488,5): error MSB3491: Could not write lines to file “obj\Development\netcoreapp3.1\BuildUtilities.csproj.FileListAbsolute.txt”. Access to the path ‘U:\Program Files\Epic Games\UE_5.0EA\Engine\Source\Programs\DotNETCommon\BuildUtilities\obj\Development\netcoreapp3.1\BuildUtilities.csproj.FileListAbsolute.txt’ is denied.
2>Done building project “BuildUtilities.csproj” – FAILED.
3>------ Rebuild All started: Project: UnrealBuildTool, Configuration: Development Any CPU ------
3>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(5488,5): error MSB3491: Could not write lines to file “obj\Development\UnrealBuildTool.csproj.FileListAbsolute.txt”. Access to the path ‘U:\Program Files\Epic Games\UE_5.0EA\Engine\Source\Programs\UnrealBuildTool\obj\Development\UnrealBuildTool.csproj.FileListAbsolute.txt’ is denied.
3>Done building project “UnrealBuildTool.csproj” – FAILED.
4>------ Rebuild All started: Project: [ProjectName], Configuration: Development_Editor x64 ------
4>‘Error_UBTMissing’ is not recognized as an internal or external command,
4>operable program or batch file.
4>’[ProjectName]Editor’ is not recognized as an internal or external command,
4>operable program or batch file.
4>’“U:\Program Files\Epic Games\UE_5.0EA\Engine\Build\BatchFiles\GetDotnetPath.bat”’ is not recognized as an internal or external command,
4>operable program or batch file.
4>Win64 using Manual SDK 10.0.18362.0
4>Target is up to date
4>Total execution time: 0.66 seconds
========== Rebuild All: 1 succeeded, 3 failed, 0 skipped ==========

1 Like

I have not been successfully been able to build in VS neither yet. It has to do with the package managers (NuGet)

Worked for me thanks!