Unreal Build Tool path is wrong when converting project from 4.26


In UE5.0EA Unreal Build Tool has been moved to its own dedicated folder in 'C:/Program Files/Epic Games/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool/UnrealBuildTool.exe

But when migrating from 4.26 we get that error:

Couldn’t find UnrealBuildTool at 'C:/Program Files/Epic Games/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool.exe

Notice this is the old path without the folder named UnrealBuildTool.

A potential fix which was provided on Unreal Slackers was to run a command line like so:

[Path to UE5]/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool/UnrealBuildTool.exe" Development Win64 -Project="[Path to Project].uproject" -game -projectfiles

I can’t confirm it is working because I have other issue atm when migrating but apparently it worked for other people. :slight_smile:

Could anyone confirm this the right command?



Few threads on this already, works for some, for others like me, we get a new error about not being able to find the project file.
Here and here
Haven’t tried it with “Development Win64” yet, just copying files to another drive before testing more.

I had this problem just now trying to open Valley of the Ancient for the 1st time using the UE5 source build.
I just copied everything inside Engine/Binaries/DotNET/UnrealBuildTool/* to Engine/Binaries/DotNET/* and it fixed the problem.

use something like

“D:<>\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.exe” -projectfiles -project=“D:\DNATG\UE5\ValleyoftheAncient\ValleyoftheAncient.uproject” -game -Engine -rocket -progress

Easiest Solution ever guys, worked for me… launch UE5, browse to the Project file through the explorer from the engine, it will then ask if you want to do XYZ and you just do it walla works…


1 Like

Create shortcut to UnrealBuildTool.exe, then move it to the parent folder, rename it UnrealBuildTool.exe , worked for me.