Foliage stretching infinitely, but no foliage in level

Our project was required to upgrade to 4.12 mid-development for production reasons. Since upgrading, we’ve been seeing the [bug described here][1], in which our foliage aligns at the world origin and stretches off into the distance in cooked builds (not in editor).

We know that this is stated fixed in 4.13, but scheduling prohibits us from upgrading, so we need to figure out how to fix whatever is causing the issue. However, nothing we try seems to be helping - not even removing all of the foliage in our build. Even deleting all of the assets in the level still doesn’t remove the problem, and the stretched grass still appears in a cook. We’ve also tried migrating into a fresh project, to no avail.

How can we remove this stretched grass from our final builds while staying in 4.12?

How are the assets being deleted? There is more than one way to delete them.

We tried both removing the foliage through the landscape tool (it currently lists 0 pieces of foliage), and just selecting all actors in the level and hitting Delete. Even after having done both of these, the stretched grass still appears when we cook a build, and it appears in all levels - not just those that the foliage was originally placed in.

Hi Matt,

This has already been confirmed fixed in our 4.13’s binary release for Preview 2 which should be going out this week for testing.

Once this releases you can test to see if that resolves the issue you’re seeing in your project. 4.13 final release should be available towards the end of August or early September.


Thank you for the reply. However, scheduling constraints are really prohibitive of going that route, as we need to deliver at the end of the week, and upgrading the engine version mere days before ship seems exceptionally risky. Are there any alternatives to remove what we’re seeing, even if it involves removing assets in the project?

There were no steps in the original UDN ticket or in the UDN post that indicated removing the asset would get rid of the issue. It’s possible for you to try, but I don’t have a test project to see this reproduced and test anything with, so I cannot guarantee that will fix it.

If you’re using source you can make the tweaks locally by adding the following to the HierarchicalInstancedStaticMesh.cpp:


This would be added around line 2200 in the PostBuildStats() function below the else check for RemovedInstances.Empty() line 2209.

Awesome, thank you!