Foliage not being lit at all

As you can see from the image, my grass planes seem to be not receiving any light, and as such are far too dark when in the lighted areas.

Here is my material setup:

Where did I go wrong? Also, the foliage is set up to not cast static shadows, but that’s about it.

Hello TommyZakh,

It appears your foliage is receiving lighting. As you can see there are shadows that are being cast on the ground underneath the planes. If you go to your main viewport and you go to lit mode you can see all of the mesh’s being lit. If it does not show up in that viewport then they are not being lit.

Try unplugging the subsurface scattering. Also you can open up the bush mesh that you have and changing the resolution of the lighting to something higher.

I know it is casting shadows, but I am more concerned by it not changing its brightness when in shadow or out in the light. Also, I saw the same effect using the Default shading model.

Do you mind explaining what you mean by “resolution of the lighting”? I thought you can only configure lightmass resolution for static-baked objects, not foliage with static shadows disabled, or maybe I’m missing something.

So, If you double click on your mesh inside of your details panel you will open up it’s properties window. On the right side of there is a section called Static Mesh Settings. In that section there is a tab called Light Map Resolution. From there you can adjust this to something like 252x256 or 512x512. The increments work like texture map resolution so you can use that as a guide for how big you want to make.

Now, I believe what is causing the light not changing is partially due to the subsurface scattering. If you unplug the subsurface scattering do you still see the same result? Also, increase the intensity of the light you have in your project that is casting those shadows. I believe you will see noticeable difference in what is receiving light. In your scene I see more light being received by the foliage that is in the direct sunlight.

I get even worse results if I unplug the subsurface scattering:

If I set my shading model to Default, my results are the same as when I have the subsurface scattering enabled i.e. subsurface scattering is not working for me.

My lightmap resolution is set to 64 right now, which is more than excessive for this grass, and leads to really long build times, but just for sake of testing. If I try to make my sun 20 times brighter, the grass becomes dark spots on the extremely bright ground:

I am sure that something is either wrong with my scene lighting or my material, but it isnt subscattering or the brightness.

Interesting. I would like to test this on my end if you are willing. If you would provide a link to dropbox with your .uproject Content and Config files from your project files. I will then attempt to recreate this issue on my end to determine whether this is a bug or not.

If you are uncomfortable with posting a link here you can go to our forums and send me a private message. You can do this by going to the forums, clicking the advanced option button, and navigating down to search for user name. Enter my name there and you will be able to send me a private message.

Is a google Drive link ok? Or does it have to be a Dropbox?

They just need a reliable hosting site that is allowed on their end, they’ve suggested Dropbox to me before.

I’ll take that as a yes, thank you for clarifying.

A google Drive link will work as well.

So, after downloading your project and experimenting I found a known issue very similar to this. It appears to be a static/stationary lighting issue where a lighting build is required and the engine collects a lighting cache. Essentially what happens is the lighting is derived from a singly source in the cache instead of driving it from the light that is influencing the foliage the most.

Currently this issue is on the TO DO list but I do not have an ETA for when or if it will be handled. The ticket number associated with it is UE-20029.

I have however a work around for you so you can progress with your development. Change all of your lights to movable so that calculation will occur in real time and bypass the cache calculation. Then go to your world settings and under Lightmass click the checkbox for Force No Precomputed Lighting. This will eliminate the build. Lastly, “and please save before you do this as you will need to restart the engine,” go to your Project Settings > Rendering > Turn off the checkbox for allow static lighting.

I was able to to get this. I recorded a movie of some grass that is moving between shadow and light. There isn’t a huge noticeable difference but you can tell that the light is influencing the grass. I apologize in advance for the quality.

Sorry for taking up so much of your time and being so annoying about this, but thanks to you it is finally working as I wanted it to:

And the dynamic lighting could be really beneficial in both the short term and long term, so thank you again!

Using the fully dynamic lighting model results in nice looking foliage, among other things.