Foliage becomes to bright

Hi everyone,

I have a problem with the foliage. When the meshs are to far away from the camera the foliage gets to bright. I dont know if this is related to the LODs. Is there a console command to adjust the LODs?
I searched a little bit on my own and found these console commands “r.ForceLOD 0” “foliage.ForceLOD 0” and entered them in WINDOW>Developers Tools>Output Window but these seemed not to work.

Hi, your sun (directional light) only has a limited distance where it casts shadows. If the trees are beyond that distance, they won’t have shadows. For out door maps, enable mesh distance fields in the project settings, then in your directional light use distance field shadows for furhter away.

Doc: Distance Field Soft Shadows | Unreal Engine Documentation

No, I don’t think you’re doing anything wrong, since you can see a difference between 300m distance field shadow distance in the first image and 1000m in the second image (also means your trees are further away than 300m).

So now they do cast shadows also at a distance, but imposters tend to look flat (unless you use something like this here Post Page). You could decrease the strength of the sub surface scattering inside the imposter material, that will make them darker against the sun.

Thanks for the quick response :slight_smile:

So I enabled mesh distance fields in the project settings and also distance field shadows in my directional light, but it hardly makes a difference even when I set everthing related to it in my directional light to max.
Am I doing something wrong?

I’m a complete beginner when it comes to materials, so I hope I’ve found the right one.
So I put the SS strenght down in one of my tree imposter materials from 0.7 to 0.1 in the hope that something would happen but unfortunately it didn’t, then I exhibited it completely but nothing either.
Now I am no longer sure whether I have turned down the right one.

Yes “SS strength” should be subsurface strength. Otherwise there is a paramter called “Brigthness”, you could try to turn that down. AFAIK subsurface strength and brightness are all you can change here. Otherwise you could capture a depth map of your tree and also make use of that inside the material Render to Texture Toolset Setup | Unreal Engine Documentation and Render 3D Imposter Sprites | Unreal Engine Documentation

I tried around a little bit but unfortunately everything didn’t really help, I also doubt that I did the right thing haha
But thank you very much for your help and your time.