Foliage BASE slips light from beneath landscape at night

Hi!! First time asking. I usually manage with other questions people ask but for this i found no explanation.

So basically I have a simple medium sized map for using in a TPS and my problem is the following:



The map is a landscape, and has these trees and many others (with the same issue) put with the foliage tool.
The thing is that the map has a day and night cycle, and the sun going under the landscape at night slips some light at the bottom of the trees. You can even feel the sun movement under the world if you really pay attention to those lightslips.

I suspect it is related with the landscape being a plane so… i dunno. This makes no sense so i have to go with other stuff.

Another important note is that I used 3 types of trees for foliaging, and I rescaled their STATIC MESHES by 3 before realising that i could spawn them bigger with the foliage tool itself. Could this have anything to do with it? Maybe static meshes have some sort of “border” and it got ruined by resizing that way?

Why i think this makes no sense:


  1. Moving the whole foliage group down a little, and then A LOT, and still light slips the same amount from the ground up, no matter the height.
  2. Changing foliage static, to movable, shadows to cast static, to not cast static… (all of this ALSO is leading me to those “lightmap size too large” issues that go for another thread)
  3. Lighting quality to preview, medium, high.
  4. Landscape has already been set to double-sided shadowing… for sun-being-below reasons.
  5. I even tried to place a massive double-sided shadowing plane under the whole landscape to try to avoid it getting light from below but for some reason trees still get the light <---- main reason why i think this makes no sense.
  6. I then got to the thought tha planes have this issue and swapped the extra plane with a thick cube and the problem persisted.

Please help me, I’m dying because so much testing now even got me to forget all the changes I have made and cannot remember what to revert to get the lighting build to not get stuck at 0%. Removing foliage shadows does it but let’s move away from that option.

Free computer specs ahead if some needs them:

GeForce GTX1060 6gb, driver 391.01.
8gb RAM
AMD A8-7600 Radeon R7, 10, Compute Cores 4C+6G (4CPUs), 3.1GHz
DirectX 11
Windows 8.1 Pro 64-Bits (6.3, build 9600)

Updating that as for now, waiting a lot does not really bother me and it seemed to be the solution to the 0% thing.
I thought i had a decent computer until i started using UE4.

PLEASE help me with that light issue!!!

Updating again! Took all the trees away and put some grass foliage. Don’t mind the “fireflies” and all the other.

This happens.



Alright forget it. If anyone ever finds this issue, here’s the solution:

As the sun is rotating down, you should ALSO set the “light source” (or whatever the sun is called, i can’t remember) intensity to 0.01, by lerping it or whatever you wish.

If the sun has any more intensity below the landscape (or maybe other geometric floors too), the foliage will start to glow at the base.

UNPROFESSIONAL and nonsensical, but here you have it.

Check This Video out, I think it has the answer you are looking for

Hey 2 years later! I’ll take it. I watched the video and it made me glad some other people asked that question lol. The video doesn’t really fix it though, but all solutions seem to be related to modifying sun color or stuff of those sorts. Some comments even name the things I tried in this post and it seemed to have worked for them, so I wonder how it would go if I tried that now.

By this time I never got into fixing those type of issues and got into straight blueprints and other areas of UE4, but this would definitely have come in handy since I still never really looked for an answer again.

Thanks for the reply!

Thanks for following up on this folks. I appreciate it.

I am new to UE4 so I don’t know all the fancy stuff, but here is my basic fix that works.
I couldn’t find an answer anywhere else.

Thank you!
This is the same I posted as an answer some years ago. If I ever get insight on that, I’ll update here.